Bug 1422353 - LibreOffice opens a small window when it starts
Summary: LibreOffice opens a small window when it starts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-15 05:14 UTC by Fred New
Modified: 2017-08-16 02:51 UTC (History)
6 users (show)

Fixed In Version: libreoffice-5.2.5.1-9.fc25 libreoffice-5.2.6.1-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-22 17:25:44 UTC


Attachments (Terms of Use)

Description Fred New 2017-02-15 05:14:01 UTC
Description of problem:
Starting LibreOffice Calc or Writer results in a unusable window about 2 inches by 4 inches. It never remembers the size of the window of the previous run.

Version-Release number of selected component (if applicable):
libreoffice-calc-5.2.5.1-6.fc25.x86_64
libreoffice-writer-5.2.5.1-6.fc25.x86_64

How reproducible: Always


Steps to Reproduce:
1. Log into a Gnome session
2. Press the window button
3. Type "writer"
4. Press <Enter>
5. If Writer starts in a full screen, double-click the top bar. If Writer starts in a window, it is already 2" by 4".

Actual results:
A small 2" by 4" window

Expected results:
A resonably-sized window matching the window that I used previously

Additional info:

Comment 1 Caolan McNamara 2017-02-15 15:12:14 UTC
remembers the last used size when I do it

Comment 2 Fred New 2017-02-16 19:55:16 UTC
What can I do to chase this down?

This works the same for both user accounts on this system, an HP Envy 17 with a wide profile 17" display.

Thinking this might be a carry-over from not formatting /home from previous releases of Fedora, I deleted the ~/.config/libreoffice directory in one account and the problem persisted.

So now I'm thinking it has to do with display geometry and Wayland, since the problem seems to have started when I upgraded from Fedora 24 to 25. I haven't noticed any other applications with similar window sizing problems, though.

Display drivers from lsmod:
nouveau              1564672  0
i915                 1249280  10
mxm_wmi                16384  1 nouveau
ttm                    94208  1 nouveau
i2c_algo_bit           16384  2 nouveau,i915
drm_kms_helper        151552  2 nouveau,i915
drm                   339968  12 nouveau,i915,ttm,drm_kms_helper
video                  40960  2 nouveau,i915
wmi                    16384  3 mxm_wmi,nouveau,hp_wmi

The nouveau driver appears to have crashed though, since dmesg shows multiple MMIO write faults.

Comment 3 Caolan McNamara 2017-02-16 20:47:49 UTC
see if it makes a difference to log out and log in via "gnome under X" instead of the default wayland, and what resolution do you use ?

Comment 4 Stephan Bergmann 2017-02-17 08:20:31 UTC
Ah, I can reproduce this on two different machines (a laptop and a workstation), both F25 under GNOME:

With Wayland,

  $ rm -rf ~/.config/libreoffice && soffice

shows the backing window so large as to cover the whole desktop, but

  $ rm -rf ~/.config/libreoffice && soffice --writer

shows a very small Writer doc.

However, with X, both

  $ rm -rf ~/.config/libreoffice && soffice

and

  $ rm -rf ~/.config/libreoffice && soffice --writer

show their respective windows so large as to cover the whole desktop.  (The way I remember it has been for me "since forever".)

Comment 5 Caolan McNamara 2017-02-17 08:54:45 UTC
yeah, that reproduces it indeed. With --impress, --draw --calc I seem to see the same initially smaller window for a moment before it expands to full size

Comment 6 Caolan McNamara 2017-02-17 16:39:28 UTC
lets go with making writer default to maximized on first start like calc and impress etc do

Comment 7 Fedora Update System 2017-02-19 19:10:59 UTC
libreoffice-5.2.6.1-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-924e076d62

Comment 8 Fedora Update System 2017-02-20 21:22:08 UTC
libreoffice-5.2.6.1-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-924e076d62

Comment 9 Fedora Update System 2017-02-22 17:25:44 UTC
libreoffice-5.2.6.1-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 RW Hornbaker 2017-08-15 21:25:27 UTC
libreoffice-5.2.7.2-6.fc25 continues to open in 2 x 4 inch window on a brand new window, as described above

Comment 11 Fred New 2017-08-16 02:51:50 UTC
This problem still exists in Fedora 26 - libreoffice-calc-5.3.5.2-2.fc26.x86_64.


Note You need to log in before you can comment on or make changes to this bug.