Bug 1422355 - [Intservice_public_324]Task "start fluentd" failed by unsupported parameter for module: label
Summary: [Intservice_public_324]Task "start fluentd" failed by unsupported parameter f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.z
Assignee: Jeff Cantrill
QA Contact: Xia Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-15 05:42 UTC by Xia Zhao
Modified: 2017-12-14 21:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-12-14 21:01:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
ansible execution log (738.26 KB, text/plain)
2017-02-15 05:42 UTC, Xia Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3438 normal SHIPPED_LIVE OpenShift Container Platform 3.6 and 3.5 bug fix and enhancement update 2017-12-15 01:58:11 UTC

Description Xia Zhao 2017-02-15 05:42:07 UTC
Created attachment 1250505 [details]
ansible execution log

Description of problem:
Deploy logging 3.5.0 stacks using ansible scripts, failed at Task "start fluentd":

TASK [openshift_logging : start fluentd] ***************************************
task path: /root/openshift-ansible/roles/openshift_logging/tasks/start_cluster.yaml:14
Using module file /root/openshift-ansible/roles/lib_openshift/library/oc_label.py
<$master> ESTABLISH SSH CONNECTION FOR USER: root
<$master> SSH: EXEC ssh -C -o ControlMaster=auto -o ControlPersist=60s -o StrictHostKeyChecking=no -o 'IdentityFile="/root/libra.pem"' -o KbdInteractiveAuthentication=no -o PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey -o PasswordAuthentication=no -o User=root -o ConnectTimeout=10 -o ControlPath=/root/.ansible/cp/ansible-ssh-%h-%p-%r $master '/bin/sh -c '"'"'/usr/bin/python && sleep 0'"'"''
failed: [$master] (item=$node) => {
    "failed": true, 
    "fluentd_host": "$node", 
    "invocation": {
        "module_args": {
            "kind": "node", 
            "label": [
                {
                    "key": "logging-infra-fluentd", 
                    "value": "true"
                }
            ], 
            "name": "$node", 
            "state": "add"
        }, 
        "module_name": "oc_label"
    }
}

MSG:

unsupported parameter for module: label

Using module file /root/openshift-ansible/roles/lib_openshift/library/oc_label.py
<$master> ESTABLISH SSH CONNECTION FOR USER: root
<$master> SSH: EXEC ssh -C -o ControlMaster=auto -o ControlPersist=60s -o StrictHostKeyChecking=no -o 'IdentityFile="/root/libra.pem"' -o KbdInteractiveAuthentication=no -o PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey -o PasswordAuthentication=no -o User=root -o ConnectTimeout=10 -o ControlPath=/root/.ansible/cp/ansible-ssh-%h-%p-%r $master '/bin/sh -c '"'"'/usr/bin/python && sleep 0'"'"''
failed: [$master] (item=$master) => {
    "failed": true, 
    "fluentd_host": "$master", 
    "invocation": {
        "module_args": {
            "kind": "node", 
            "label": [
                {
                    "key": "logging-infra-fluentd", 
                    "value": "true"
                }
            ], 
            "name": "$master", 
            "state": "add"
        }, 
        "module_name": "oc_label"
    }
}

MSG:

unsupported parameter for module: label


PLAY RECAP *********************************************************************
$master : ok=226  changed=23   unreachable=0    failed=1   



Version-Release number of selected component (if applicable):
https://github.com/openshift/openshift-ansible/ -b master

How reproducible:
Always

Steps to Reproduce:
1.Deploy logging 3.5.0 stacks by using ansible


Actual results:
Logging deployment failed

Expected results:
Logging deployment should succeed

Additional info:
Ansible log attached

Comment 1 Xia Zhao 2017-02-15 05:43:56 UTC
Blocks logging 3.5.0 stacks' deployment using ansible. About 70% scenarios effected.

Comment 2 Xia Zhao 2017-02-15 07:42:43 UTC
Remove keyword "TestBlocker" since this can be workarounded by manually scale up curator,es,kibana pods after deployment.

Comment 3 Xia Zhao 2017-02-16 03:29:48 UTC
Verified with the code in PR https://github.com/openshift/openshift-ansible/pull/3373 with branch https://github.com/ewolinetz/openshift-ansible/tree/logging_fix_kibana_routes, this issue no longer exist. Will set to verified once PR merged. Please feel free to send this back ON_QA.

Comment 4 ewolinet 2017-02-16 16:03:05 UTC
PR has been merged

Comment 5 Xia Zhao 2017-02-17 08:59:35 UTC
Verified with https://github.com/openshift/openshift-ansible -b master, issue was fixed. Thanks.

Comment 8 errata-xmlrpc 2017-12-14 21:01:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3438


Note You need to log in before you can comment on or make changes to this bug.