Bug 142237 - zip -d arch.zip ./file fails
zip -d arch.zip ./file fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: zip (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-08 06:35 EST by Doncho N. Gunchev
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 04:26:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doncho N. Gunchev 2004-12-08 06:35:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
    The archive at http://www.xs4all.nl/~bsarempt/python/p.zip
contains files with './' path like as './edit.html'. Trying to remove
any of these fails.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. wget http://www.xs4all.nl/~bsarempt/python/p.zip
2. zip -d p.zip ./edit.html


Actual Results:  zip -d p.zip ./edit.html

zip error: Nothing to do! (p.zip)


Expected Results:  zip -d p.zip ./edit.html
deleting: ./edit.html


Additional info:

    Roland Illig found a workaround: 'zip -d p.zip [.]/edit.html'.
This breaks mc's vfs and probably others'. For more info:
http://mail.gnome.org/archives/mc-devel/2004-December/msg00031.html
and bug # 141844. The command -r is handled (maybe) correctly, ex:
'zip -r p.zip edit.html' replaces './edit.html' with the new 'edit.html'.
Comment 1 Leonard den Ottolander 2004-12-10 17:21:54 EST
Doncho,

Please don't set the architecture if the issue is not architecture
specific.
Comment 2 Ivana Varekova 2005-02-01 04:11:33 EST
Thank you for your notice.
The problem was fixed.
Ivana Varekova
Comment 3 Ivana Varekova 2005-02-04 04:26:32 EST
Fixed in zip-2.3-29.

Note You need to log in before you can comment on or make changes to this bug.