Bug 1422444 - 4.9.5-200.fc25.aarch64 fails to boot at all on Mustang A3 hardware
Summary: 4.9.5-200.fc25.aarch64 fails to boot at all on Mustang A3 hardware
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2017-02-15 11:11 UTC by Richard W.M. Jones
Modified: 2019-01-09 12:54 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-02-21 14:57:14 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2017-02-15 11:11:46 UTC
Description of problem:

EFI stub: Booting Linux Kernel...
EFI stub: Using DTB from configuration table
EFI stub: Exiting boot services and installing virtual address map...
L3c Cache: 8MB


Synchronous Exception at 0x00000043F9B71720
0: FP 0x00000043FFA78710 SP 0x00000043FFA78710 PC 0x00000043FA38171C
1: FP 0x00000043FFA78760 SP 0x00000043FFA78720 PC 0x00000043FA381894
2: FP 0x00000043FFA78790 SP 0x00000043FFA78770 PC 0x00000043FA383780
3: FP 0x00000043FFA787C0 SP 0x00000043FFA787A0 PC 0x00000043FA3805B0
4: FP 0x00000043FFA78910 SP 0x00000043FFA787D0 PC 0x00000043FA37ED38
5: FP 0x00000043FFA789E0 SP 0x00000043FFA78920 PC 0x00000043FA37AE08
6: FP 0x00000043FFA78A00 SP 0x00000043FFA789F0 PC 0x00000043F7FA7D14
7: FP 0x00000043FFA78A10 SP 0x00000043FFA78A10 PC 0x00000043F7FA79F8
8: FP 0x00000043FFA78A60 SP 0x00000043FFA78A20 PC 0x00000043F7FEC1D4
9: FP 0x00000043FFA78A90 SP 0x00000043FFA78A70 PC 0x00000043F7F6E194
10: FP 0x00000043FFA78B00 SP 0x00000043FFA78AA0 PC 0x00000043F7F6DD68
11: FP 0x00000043FFA78B80 SP 0x00000043FFA78B10 PC 0x00000043F7F69CF4
12: FP 0x00000043FFA78BF0 SP 0x00000043FFA78B90 PC 0x00000043F7F6A0F0
13: FP 0x00000043FFA78C10 SP 0x00000043FFA78C00 PC 0x00000043F7F6A1EC
14: FP 0x00000043FFA78C40 SP 0x00000043FFA78C20 PC 0x00000043F7F6A248
15: FP 0x00000043FFA78C50 SP 0x00000043FFA78C50 PC 0x00000043FA654B68
16: FP 0x00000043FFA78CA0 SP 0x00000043FFA78C60 PC 0x00000043FFA7BBD0
17: FP 0x00000043FFA78CF0 SP 0x00000043FFA78CB0 PC 0x00000043FF9942DC
18: FP 0x00000043FFA78D50 SP 0x00000043FFA78D00 PC 0x00000043FF98DD18
19: FP 0x00000043FFA78DA0 SP 0x00000043FFA78D60 PC 0x00000043FF98C474
20: FP 0x00000043FFA78DD0 SP 0x00000043FFA78DB0 PC 0x00000043FF98BB40
21: FP 0x00000043FFA78E80 SP 0x00000043FFA78DE0 PC 0x00000043FF98BD48
22: FP 0x00000043FFA78EF0 SP 0x00000043FFA78E90 PC 0x00000043FFA797F4
23: FP 0x00000043FFA78FE0 SP 0x00000043FFA78F00 PC 0x00000043FFA79270

and it just hangs there.


Version-Release number of selected component (if applicable):

kernel 4.9.5-200.fc25.aarch64

How reproducible:

At least once.

Steps to Reproduce:
1. Install kernel and reboot.

Comment 1 Richard W.M. Jones 2017-02-15 11:12:40 UTC
Hardware:

X-Gene Mustang Board
Boot firmware (version 1.15.23 built at 13:21:52 on Nov 24 2015)
TianoCore 1.1.0 UEFI 2.4.0 Nov 24 2015 13:21:07
CPU: APM ARM 64-bit Potenza Rev A3 2400MHz PCP 2400MHz
     32 KB ICACHE, 32 KB DCACHE
     SOC 2000MHz IOBAXI 400MHz AXI 250MHz AHB 200MHz GFC 125MHz
Board: X-Gene Mustang Board
Slimpro FW:
        Ver: 2.4 (build 01.15.23.00 2015/11/24)
        PMD: 950 mV
        SOC: 950 mV

Last working kernel is 4.8.12-300.fc25.aarch64

Comment 2 Richard W.M. Jones 2017-02-15 11:19:42 UTC
Fixed by https://patches.linaro.org/patch/93022/
according to hrw.

Comment 3 Riku Voipio 2017-02-15 11:21:19 UTC
The patch is included in 4.9.9 that should fix the regression

Comment 4 Richard W.M. Jones 2017-02-21 14:57:14 UTC
Looks like this is now fixed with
kernel-4.9.9-200.fc25.aarch64


Note You need to log in before you can comment on or make changes to this bug.