Bug 1422464 (CVE-2017-2628) - CVE-2017-2628 curl: negotiate not treated as connection-oriented (incomplete fix for CVE-2015-3148)
Summary: CVE-2017-2628 curl: negotiate not treated as connection-oriented (incomplete ...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2017-2628
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1429761
Blocks: 1415298 1422465
TreeView+ depends on / blocked
 
Reported: 2017-02-15 11:50 UTC by Martin Prpič
Modified: 2019-09-29 14:07 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
It was found that the fix for CVE-2015-3148 in curl was incomplete. An application using libcurl with HTTP Negotiate authentication could incorrectly re-use credentials for subsequent requests to the same server.
Clone Of:
Environment:
Last Closed: 2017-03-29 06:43:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:0847 normal SHIPPED_LIVE Moderate: curl security update 2017-03-29 10:32:29 UTC

Description Martin Prpič 2017-02-15 11:50:28 UTC
It was found that the fix for CVE-2015-3148 did not correctly backported to curl in RHEL 6 because it did not reflect the fact that the HAVE_GSSAPI define was meanwhile substituted by USE_HTTP_NEGOTIATE.

The original issue was described as:

It was discovered that libcurl could incorrectly reuse Negotiate authenticated HTTP connections for subsequent requests. If an application using libcurl established a Negotiate authenticated HTTP connection to a server and sent subsequent requests with different credentials, the connection could be re-used with the initial set of credentials instead of using the new ones.

This issue was introduced in RHEL 6.7 and affects RHEL 6 curl only.

Comment 1 Martin Prpič 2017-02-15 12:44:03 UTC
Acknowledgments:

Name: Paulo Andrade (Red Hat)

Comment 8 errata-xmlrpc 2017-03-29 06:32:48 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 6

Via RHSA-2017:0847 https://rhn.redhat.com/errata/RHSA-2017-0847.html


Note You need to log in before you can comment on or make changes to this bug.