Bug 142247 - dmidecode and irqbalance lack man pages.
Summary: dmidecode and irqbalance lack man pages.
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel-utils   
(Show other bugs)
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alan Cox
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-08 15:31 UTC by Björn Augustsson
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:11:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Björn Augustsson 2004-12-08 15:31:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
There are no man pages nor documentation in /usr/share/doc for these
binaries.

dmidecode also does not take either --version nor --help on the
command line, but appears to support some kind of arguments. (it says
stuff along the lines of "--help: No such file or directory".

irqbalance scarily starts running with the --help argument and hangs
around.


Version-Release number of selected component (if applicable):
kernel-utils-2.4-8.37.6

How reproducible:
Always

Steps to Reproduce:
1. man dmidecode
2. man irqbalance
3. 
    

Actual Results:  nothing

Expected Results:  enlightenment.

Additional info:

The nahant beta has a man page for irqbalance. But not for dmidecode.

Comment 1 Jean Delvare 2005-03-02 10:44:19 UTC
(I am the maintainer of dmidecode.)

dmidecode has a man page since version 2.4. Command-line interface was not
documented yet, because it was very limited, intended for debugging only and
subject to changes.

dmidecode supports --help and --version since version 2.6 (released two days
ago). Command-line interface is fully documented there.


Comment 2 Björn Augustsson 2005-05-24 08:11:16 UTC
RHEL 3 update 5 (maybe earlier, haven't checked) has a man page for irqbalance. 

Still nothing for dmidecode though.


Comment 4 RHEL Product and Program Management 2007-10-19 19:11:55 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.