Bug 1422532 - gcc7 compiled firefox looks seriously broken
gcc7 compiled firefox looks seriously broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
: 1422619 1425729 1425770 1426181 (view as bug list)
Depends On:
Blocks: AlphaBlocker/F26AlphaBlocker
  Show dependency treegraph
 
Reported: 2017-02-15 08:24 EST by Mamoru TASAKA
Modified: 2017-05-22 04:57 EDT (History)
19 users (show)

See Also:
Fixed In Version: firefox-51.0.1-6.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-23 14:37:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot with gcc6 compiled firefox (191.16 KB, image/png)
2017-02-15 08:27 EST, Mamoru TASAKA
no flags Details
screenshot with gcc7 compiled firefox (139.78 KB, image/png)
2017-02-15 08:30 EST, Mamoru TASAKA
no flags Details
startup with 51.0.1-5.fc26 showing crash reporter (1017.35 KB, image/png)
2017-02-23 08:49 EST, Mamoru TASAKA
no flags Details
gdb log (82.31 KB, text/plain)
2017-02-23 10:34 EST, Mamoru TASAKA
no flags Details

  None (edit)
Description Mamoru TASAKA 2017-02-15 08:24:16 EST
Description of problem:
Looks like with gcc7 compiled firefox (firefox-51.0.1-3.fc26), browsing any web page looks seriously broken.

Just downgrading firefox only to firefox-51.0.1-2.fc26 restores "good" looking at browsing web pages.


Version-Release number of selected component (if applicable):
firefox-51.0.1-3.fc26

How reproducible:
100%

Steps to Reproduce:
1. browse any web pages with firefox-51.0.1-3.fc26
2.
3.

Actual results:
Very bad.

Expected results:
As was with firefox-51.0.1-2.fc26

Additional info:
Some screenshot will be attached.
Comment 1 Mamoru TASAKA 2017-02-15 08:27 EST
Created attachment 1250608 [details]
screenshot with gcc6 compiled firefox

https://start.fedoraproject.org/ with firefox-51.0.1-2.fc26 . Looks normal.
Comment 2 Mamoru TASAKA 2017-02-15 08:30 EST
Created attachment 1250609 [details]
screenshot with gcc7 compiled firefox

https://start.fedoraproject.org/ with firefox-51.0.1-3.fc26 . This one was compiled with gcc7.

Note that
- the right side and bottom side is black
- URL bar is not shown
- And some other things are also broken.
Comment 3 Adam Williamson 2017-02-15 20:54:17 EST
*** Bug 1422619 has been marked as a duplicate of this bug. ***
Comment 4 Adam Williamson 2017-02-21 11:30:39 EST
This renders cockpit basically unusable:

https://openqa.fedoraproject.org/tests/57165

Given how bad this is I'm gonna nominate it as an Alpha blocker, as a violation of "It must be possible to run the default web browser and a terminal application from all release-blocking desktop environments. ... The web browser must be able to download files, load extensions (if applicable), and log into FAS." - arguably, you can't reasonably do all those things with a Firefox that looks like this. openQA sure can't. :P
Comment 5 Jan Horak 2017-02-22 04:07:19 EST
*** Bug 1425729 has been marked as a duplicate of this bug. ***
Comment 6 Martin Stransky 2017-02-22 06:33:40 EST
*** Bug 1425770 has been marked as a duplicate of this bug. ***
Comment 7 Martin Stransky 2017-02-22 07:29:43 EST
As a workaround you can use our flatpak packages:

https://firefox-flatpak.mojefedora.cz/

or install binary from mozilla.com.
Comment 8 Kevin Fenzi 2017-02-22 09:35:04 EST
You can also downgrade to 
https://koji.fedoraproject.org/koji/buildinfo?buildID=836421

which currently has no dep issues or the like.
Comment 9 Kai Engert (:kaie) 2017-02-22 10:47:54 EST
Does anyone understand what's happening?
Comment 10 Martin Stransky 2017-02-22 11:38:10 EST
(In reply to Kai Engert (:kaie) from comment #9)
> Does anyone understand what's happening?

Build without optimization works fine so I expect it's some -O3 miscompilation/FF bug whatever. Looking into it.
Comment 11 Martin Stransky 2017-02-23 07:21:24 EST
New build without -O3 optimization is here:
https://koji.fedoraproject.org/koji/taskinfo?taskID=18011812
Comment 12 Mamoru TASAKA 2017-02-23 08:49 EST
Created attachment 1256931 [details]
startup with 51.0.1-5.fc26 showing crash reporter

(In reply to Martin Stransky from comment #11)
> New build without -O3 optimization is here:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=18011812

Doesn't seem good.. For me this crashes on startup (i.e. this does not launch) and crash reporter appears.
Comment 13 Mamoru TASAKA 2017-02-23 08:52:41 EST
(In reply to Mamoru TASAKA from comment #12)
> Created attachment 1256931 [details]
> startup with 51.0.1-5.fc26 showing crash reporter

Although this picture's file name is "startup-ff-51.0.1-2.fc26.x86_64.png", this is actually with firefox-51.0.1-5.fc26.x86_64
Comment 14 Mamoru TASAKA 2017-02-23 10:34 EST
Created attachment 1256966 [details]
gdb log

gdb backtrace for firefox-51.0.1-5.fc26.x86_64
Comment 15 Yanko Kaneti 2017-02-23 11:32:47 EST
*** Bug 1426181 has been marked as a duplicate of this bug. ***
Comment 16 Kai Engert (:kaie) 2017-02-23 11:51:50 EST
I've also experimented with local builds, because I need to test a code change to firefox, and the -O2 build crashed for me, too.

Instead of the approach that Martin had commited, I added the following statement (which is usually used for firefox debug builds):

   MOZ_OPT_FLAGS=$(echo "$MOZ_OPT_FLAGS" | %{__sed} -e 's/-O2//')

This change disables the -O2 flag, that is obtained from this line:
  MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS" | %{__sed} -e 's/-Wall//')

The local build I've produced that way works for me, without apparent visual issues.
Comment 17 Martin Stransky 2017-02-23 12:19:42 EST
(In reply to Mamoru TASAKA from comment #12)
> Created attachment 1256931 [details]
> startup with 51.0.1-5.fc26 showing crash reporter
> 
> (In reply to Martin Stransky from comment #11)
> > New build without -O3 optimization is here:
> > https://koji.fedoraproject.org/koji/taskinfo?taskID=18011812
> 
> Doesn't seem good.. For me this crashes on startup (i.e. this does not
> launch) and crash reporter appears.

That seems to be mozbz#1321579
Comment 18 Martin Stransky 2017-02-23 14:37:22 EST
New builds are available at https://koji.fedoraproject.org/koji/buildinfo?buildID=861526
Comment 19 Mamoru TASAKA 2017-02-23 15:18:21 EST
(In reply to Martin Stransky from comment #18)
> New builds are available at
> https://koji.fedoraproject.org/koji/buildinfo?buildID=861526

This works for me, thank you!
Comment 20 Jakub 2017-02-24 07:24:08 EST
hasnt there been the change in gcc in fedora that allows indefined use of functions or something..? (disables warning about them, that prevents compiling)

Note You need to log in before you can comment on or make changes to this bug.