Bug 1422535 - The default interface for management network configuration in the HE installation isn't the active interface
Summary: The default interface for management network configuration in the HE installa...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Network
Version: 2.1.0
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: ovirt-4.2.0
: 2.2.0
Assignee: Ido Rosenzwig
QA Contact: Michael Burman
URL:
Whiteboard:
: 1422536 (view as bug list)
Depends On: 1455169
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-15 13:34 UTC by Michael Burman
Modified: 2019-04-28 13:35 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 10:52:04 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
screenshot (32.15 KB, image/png)
2017-02-15 13:34 UTC, Michael Burman
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84703 master MERGED src: plugins: The default interface for management network configuration is the active NIC 2020-02-17 02:58:12 UTC

Description Michael Burman 2017-02-15 13:34:40 UTC
Created attachment 1250610 [details]
screenshot

Description of problem:
The default interface for management network configuration in the HE wizard installation isn't the active interface as it should.

When running the Hosted Engine deploy via the HE wizard in cockpit, it displays as default the wrong interface fro the management network configuration.
It should always by default display the active interface, the nic which has the host IP.

Version-Release number of selected component (if applicable):
cockpit-ws-126-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Run hosted engine via cockpit wizard

Actual results:
The default interface for the management network configuration isn't the interface with the hosts IP

Expected results:
The default interface must be the one with the host's IP

Attaching screenshot - in my setup the active connection is enp4s0 and this should the default interface as well. not ens1f1.

Comment 1 Dominik Perpeet 2017-02-16 08:35:25 UTC
*** Bug 1422536 has been marked as a duplicate of this bug. ***

Comment 2 Dominik Perpeet 2017-02-16 08:37:04 UTC
I'm not sure if cockpit is the right component for this, since the HE installation wizard is not part of cockpit itself.

Comment 5 Sandro Bonazzola 2017-02-20 08:44:52 UTC
cockpit-ovirt is just a presentation layer. the issue is into hosted-engine setup

Comment 7 Michael Burman 2017-12-12 07:16:55 UTC
Verified on - ovirt-hosted-engine-setup-2.2.0-2.el7ev.noarch using:

rhvh-4.2.0.5-0.20171207.0+1

cockpit-ws-151-1.el7.x86_64
cockpit-bridge-151-1.el7.x86_64
cockpit-system-151-1.el7.noarch
cockpit-storaged-151-1.el7.noarch
cockpit-ovirt-dashboard-0.11.1-0.6.el7ev.noarch
cockpit-dashboard-151-1.el7.x86_64
cockpit-151-1.el7.x86_64

ovirt-hosted-engine-setup-2.2.0-2.el7ev.noarch
ovirt-hosted-engine-ha-2.2.0-1.el7ev.noarch

rhvm-appliance-4.2-20171207.0.el7.noarch

Comment 8 Sandro Bonazzola 2017-12-20 10:52:04 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.