Bug 142256 - Web Collage screensaver is enabled in default random list and displays pornographic material
Web Collage screensaver is enabled in default random list and displays pornog...
Status: CLOSED DUPLICATE
Product: Fedora
Classification: Fedora
Component: kdeartwork (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-08 11:27 EST by Michael Schwendt
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 12:06:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2004-12-08 11:27:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
As seen and analyzed on fedora-list-de, when configuring KDE to use
the "Random" screensaver, one of the randomly activated screensavers
will be "Web Collage". It displays random pictures downloaded from the
Internet, including pornographic material occasionally, as reported by
the user.

kdebase-3.3.1/kscreensaver/random.cpp confirms that the screen saver
is included in the default list and there are no way to exclude it
other than deleting

  /usr/share/applnk/System/ScreenSavers/webcollage.desktop



Version-Release number of selected component (if applicable):
kdeartwork-3.3.1-4.1 / kdebase-3.3.1-4.1

How reproducible:
Always



Additional info:

In the xscreensaver package, which contains the screensaver, too:

* Tue Sep 21 1999 Bill Nottingham <notting@redhat.com>

- take webcollage out of random list (for people who pay for bandwidth)
Comment 1 Sitsofe Wheeler 2004-12-08 11:51:16 EST
This is a dup of bug 139513
Comment 2 Ngo Than 2004-12-08 12:06:01 EST
it's bug in xscreensaver, which i already fixed in xscreensaver-4.1.8-13 or newer.


*** This bug has been marked as a duplicate of 139513 ***
Comment 3 Sitsofe Wheeler 2004-12-09 10:09:36 EST
Wow this was marked a dup but bugzilla says DUPLICATE of bug <missing bug number>

Note You need to log in before you can comment on or make changes to this bug.