This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1422583 - libgit2 needs rebuild against http-parser 2.7.1
libgit2 needs rebuild against http-parser 2.7.1
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: libgit2 (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pete Walter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-02-15 11:10 EST by Erik Johnson
Modified: 2017-04-21 06:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-21 06:29:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shell output demonstrating libgit2's failure to fetch from a repo, along with evidence this is due to incompatible libhttp_parser (4.71 KB, text/plain)
2017-02-15 11:10 EST, Erik Johnson
no flags Details

  None (edit)
Description Erik Johnson 2017-02-15 11:10:25 EST
Created attachment 1250646 [details]
Shell output demonstrating libgit2's failure to fetch from a repo, along with evidence this is due to incompatible libhttp_parser

Description of problem:

http-parser was upgraded to 2.7.1, and libgit2 (which depends on it) was never rebuilt.

[root@784e8a8c5028 /]# rpm -qi http-parser | egrep 'Version|Release|Build Date'
Version     : 2.7.1
Release     : 3.el7
Build Date  : Wed Oct 26 17:35:58 2016
[root@784e8a8c5028 /]# rpm -qi libgit2 | egrep 'Version|Release|Build Date'
Version     : 0.21.5
Release     : 1.el7
Build Date  : Sat Mar 14 11:17:20 2015


Version-Release number of selected component (if applicable):

libgit2-0.21.5-1.el7.x86_64


How reproducible:

100% reproducible for https(s) remotes when you use bindings for libgit2 (such as pygit2)


Steps to Reproduce:

See the attached text file.


Actual results:

A fetch fails with a traceback.


Expected results:

The fetch should not fail.


Additional info:

Downgrading http-parser to 2.0.5 allows the fetch to proceed.


Recommendation:

Rebuild libgit2 against http-parser 2.7.1.
Comment 1 Erik Johnson 2017-02-15 11:15:53 EST
libgit2 probably also needs a Requires for http-parser 2.7.1 to ensure that this sort of issue is caught in the future.
Comment 2 Erik Johnson 2017-04-18 23:20:30 EDT
Just checking in as it has been over 60 days since I filed this issue. Any word on when we can expect this rebuild to be completed? It should not take much effort to do this.
Comment 3 Erik Johnson 2017-04-18 23:24:23 EDT
Disregard. The rebuild has taken place, the mirror on the docker image I was using to test was out of date.

This issue can be closed.
Comment 4 Pete Walter 2017-04-21 06:29:48 EDT
Thanks for verifying!

Note You need to log in before you can comment on or make changes to this bug.