Bug 142268 - External Monitor shows 640x480 panning window, not actual desktop size
External Monitor shows 640x480 panning window, not actual desktop size
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-08 12:35 EST by redhat-bugs
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-22 08:45:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
What happens when the Acer is connected (42.40 KB, text/plain)
2004-12-08 12:35 EST, redhat-bugs
no flags Details
What happens when the Sony is connected (51.43 KB, text/plain)
2004-12-08 12:36 EST, redhat-bugs
no flags Details
What happens when nothing is connected (34.17 KB, text/plain)
2004-12-08 12:37 EST, redhat-bugs
no flags Details
My xorg.conf (2.74 KB, text/plain)
2004-12-08 12:38 EST, redhat-bugs
no flags Details

  None (edit)
Description redhat-bugs 2004-12-08 12:35:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I have this new Dell D600 laptop which I have installed FC2 on.  It
has a SXVGA+ (ie, 1400x1050) display.  X will display at this
resolution (at 24-bit depth) on the LCD display, no problem.
However, when I plug the laptop into a docking station which has an
Acer 77e 17" monitor attached to it, the Acer displays the 1400x1050
desktop, as viewed through a panning 640x480 window.



Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-2.i386

How reproducible:
Always

Steps to Reproduce:
1. Plug Acer monitor into laptop.
2. Boot Linux.

    

Actual Results:  X display is a 640x480 panning window on a desktop
that is 1400x1050.

Expected Results:  X display should be non-panning 1400x1050.

Additional info:

I have this new Dell D600 laptop which I have installed FC2 on.  It
has a SXVGA+ (ie, 1400x1050) display.  X will display at this
resolution (at 24-bit depth) on the LCD display, no problem.
However, when I plug the laptop into a docking station which has an
Acer 77e 17" monitor attached to it, the Acer displays the 1400x1050
desktop, as viewed through a panning 640x480 window.

Experimentation has shown that the presence or absence of the dock
(ie just plugging the Acer straight into the back of the Dell) makes
no difference.

I know it is possible to have this monitor display 1400x1050x24 --
Windows does it.  I've also driven this monitor at 1600x1280x24 when
attached to a different linux system.  I also know that it is
possible to have this Linux display properly at this resolution on an
external monitor -- I have a Sony G400 at the office which does it.

I have gone through the FC2 System Settings -> Display applet
and have explicitly defined my monitor as an AcerView 77e.  I have
confirmed in my /etc/X11/xorg.conf that there is an appropriate
monitor defined:

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Acer 77e"
        HorizSync    30.0 - 72.0
        VertRefresh  50.0 - 120.0
EndSection

The presence and/or absence of this section doesn't appear to change
anything.

When I boot the laptop at the office, it is connected to the Sony G400
and it does the appropriate thing.  At home, it still does not behave
with the Acer.

In the Xorg.0.log, I've noticed that when connected to the Sony, the
log reports:

(II) RADEON(0): Displays Detected: Monitor1--Type 2, Monitor2--Type 1

(II) RADEON(0): Monitor2 EDID data ---------------------------
(II) RADEON(0): Manufacturer: SNY  Model: 290  Serial#: 8011257
(II) RADEON(0): Year: 2000  Week: 25
(II) RADEON(0): EDID Version: 1.2
[...lots of monitor stuff trimmed...]
(II) RADEON(0): End of Monitor2 EDID data --------------------
(II) RADEON(0):
(II) RADEON(0): Primary Display == Type 2
(II) RADEON(0): Clone Display == Type 1
        
...which tells me that it is detecting the Sony all by itself and
making appropriate assumptions.  Where as when it is connected ot the
Acer, I see:

(II) RADEON(0): Displays Detected: Monitor1--Type 2, Monitor2--Type 1

(II) RADEON(0):
(II) RADEON(0): Primary Display == Type 2
(II) RADEON(0): Clone Display == Type 1

...which tells me that either the Acer isn't detected at all, or it
is detected improperly.  However, I still don't know what to do about
it.  I'm starting to suspect that the config file is merely there for
my amusement and xorg is trying to auto-detect things at startup
rather than read the config file.

What I can't find is an explanation as to why I'm getting this 640x480
on an external monitor which is clearly capable of displaying much
more, nor an explanation of how to fix it.  All pages on the web I've
found suggest that it means that my monitor can't run the video mode I
selected (known to be false) or that my video card can't run the video
mode I selected
(also known to be false).  It has to be a configuration problem.

Incidentally, a co-worker has the same problem, only he's started with
FC2 and done an "upgrade" install to FC3.

I will attach the following files:
- my xorg.conf file;
- a log file showing what happens with the Acer;
- a log file showing what happens with the Sony;
- a log file showing what happens when nothing is plugged in.
Comment 1 redhat-bugs 2004-12-08 12:35:55 EST
Created attachment 108127 [details]
What happens when the Acer is connected
Comment 2 redhat-bugs 2004-12-08 12:36:47 EST
Created attachment 108128 [details]
What happens when the Sony is connected
Comment 3 redhat-bugs 2004-12-08 12:37:25 EST
Created attachment 108130 [details]
What happens when nothing is connected
Comment 4 redhat-bugs 2004-12-08 12:38:09 EST
Created attachment 108131 [details]
My xorg.conf
Comment 5 redhat-bugs 2004-12-09 10:15:37 EST
Opened this as a bug with xorg; see
https://bugs.freedesktop.org/show_bug.cgi?id=2035

Their response: NOTABUG

Details:

------- Additional Comments From agd5f@yahoo.com  2004-12-08 14:25 -------
the radeon driver defaults to driving each display with a separate
crtc (called
clone mdoe).  if it can't find the DDC data for the attached monitor
it defaults
to 640x480@60Hz to avoid potentially damaging you monitor.  You can either
disable clone mode (in which case crtc1 will drive both outputs) or
add the use
the clonehsync and clonevrefresh options (to tell the driver the monitor's
limits when it can't get DDC data).  see that radeon man page for more
about the
options.

------- Additional Comments From agd5f@yahoo.com  2004-12-08 14:30 -------
for your coworker, in 6.8.x the options have changed a bit, see the
radeon man
page for more.
Comment 6 redhat-bugs 2004-12-09 12:31:23 EST
...so clearly the problem is that there's no way to set the required
Radeon options through the display control panel.  Would this be an
enhancement request?  (I doubt it -- the current fashion is to remove
options from GUI applications, not add more.)
Comment 7 Mike A. Harris 2004-12-22 08:45:18 EST
Upstream is right, this is not a bug.  If your monitor or LCD panel
can not be DDC probed, or otherwise autodetected, then the driver
must make assumptions as to how to drive the hardware in a safe
manner without damaging the panel or monitor.  That basically means
choosing low resolution/refresh which is unlikely to damage the
display.

Some hardware is not autodetectable at all.  I don't know wether this
is the case for your hardware or not.  Windows generally wont ever
show this type of problem because either WIndows autodetects the 
hardware, or if not detectable, Windows has .INF files that specify
the hardware's capabilities, which are supplied directly by the
manufacturers.  There are also other possibilities that are more
complex than I will get into in a bug report.

The bottom line basically though, is that if DDC is unavailable, for
whatever reason, you must manually configure the display in your
X server config file, or the drivers will use defaults chosen to
be as safe as possible.

My recommendation is to upgrade to Fedora Core 3 (our currently
supported release), and update the OS to all latest rpms via yum
or up2date.  After doing so, run:

    system-config-display --reconfig

Then reboot completely to do full hardware reset.  In the new
startup, run X and see if things are better at all.  If not,
then experiment with the various Radeon driver specific options
on the "radeon" manpage, and with configuring the display panel
via xorg.conf.  If you require assistance at all, use the X.Org
xorg@freedesktop.org mailing list to seek help.

You may also want to repeat this with the xorg-x11 from rawhide,
which is a newer release with several Radeon driver fixes and
enhancements.  This may or may not help your problem depending
on wether it is a real driver issue, or just lack of DDC
capability in your system.

After doing all of this, if you still believe there may be a real
bug at heart, feel free to file a new bug in freedesktop.org bugzilla
for review, indicating the current OS release, xorg release, etc.
that you are using.  Generally speaking, if X.Org does not consider
something an X.Org bug, Red Hat X developers and other community
X developers are likely to arrive at similar conclusions.

Setting status to "CURRENTRELEASE"
Comment 8 redhat-bugs 2004-12-22 09:49:17 EST
Yeah, I get that.  It isn't an Xorg bug.

In the FC3 case, the answer is to add lines:

   Option      "CRT2HSync" "30.0 - 82.0"
   Option      "CRT2VRefresh" "50.0 - 90.0"

..to the "Device" section describing my radeon device. These values
were divined by manually adding the monitor through the Display
control panel, and then transfering those values into the Option fields.

(As the response from xorg says, consult your "radeon" man page for
the equivilent commands in FC2.)

The problem is that setting the monitor type in the
system-config-display should cause the system to use that monitor
type, and it doesn't (because the Radeon is treating the external
monitor plug as a separate display, which may be fine, but there's no
way to change that from system-config-display, which isn't).

This, incidentally, is still true in FC3 with all the current updates
applied.

So.  Should I refile this as a FC3 bug in system-config-display?

Note You need to log in before you can comment on or make changes to this bug.