Bug 1422764 - Epiphany crashes while browsing sechat.org
Summary: Epiphany crashes while browsing sechat.org
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: epiphany
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Catanzaro
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-16 06:49 UTC by Ildar Akhmetgaleev
Modified: 2017-02-23 03:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-23 03:52:00 UTC
Type: Bug


Attachments (Terms of Use)
Crash backtrace. (70.33 KB, text/plain)
2017-02-16 06:49 UTC, Ildar Akhmetgaleev
no flags Details

Description Ildar Akhmetgaleev 2017-02-16 06:49:08 UTC
Created attachment 1250788 [details]
Crash backtrace.

Description of problem:
Epiphany randomly crashes while I browse sechat.org.

Version-Release number of selected component (if applicable):
Web 3.22.6


How reproducible:
Login in to sechat.org, or may be any other Diaspora* pod. Browse around, click links, check notifications.

Actual results:
Crash.

Expected results:
No crash.

Additional info:
Back trace is attached.

Comment 1 Michael Catanzaro 2017-02-16 16:19:39 UTC
Memory corruption. If you can reproduce, it would be really awesome if you could catch it in valgrind.

Comment 2 Ildar Akhmetgaleev 2017-02-17 06:57:59 UTC
(In reply to Michael Catanzaro from comment #1)
> Memory corruption. If you can reproduce, it would be really awesome if you
> could catch it in valgrind.

Can you give me instructions how to catch it in valgrind?

Comment 3 Michael Catanzaro 2017-02-17 15:49:55 UTC
Just 'valgrind epiphany' should be enough, since it's a UI process issue. Ifval

Comment 4 Michael Catanzaro 2017-02-17 15:50:24 UTC
(In reply to Michael Catanzaro from comment #3)
> Just 'valgrind epiphany' should be enough, since it's a UI process issue.
> Ifval

Sorry, I guess I was planning to write something else there at the end. Ignore that last bit!

Comment 5 Ildar Akhmetgaleev 2017-02-18 04:59:17 UTC
Still can not catch fault in fedora, but got crash with valgrind in debian https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=855261#10

Comment 6 Michael Catanzaro 2017-02-18 15:09:43 UTC
The valgrind log shows a different, unrelated crash (from an X window system error). I wonder if that one might have been fixed in 2.14.5. Please wait for that update and see if you can still reproduce it then; if so, we should report it upstream (on WebKit Bugzilla).

Back to this issue. The problem here is the memory corruption could be in Epiphany, or WebKit (most likely), or any dependency: we really have no clue unless we can catch it in valgrind. So nothing actionable yet, I'm afraid.

Comment 7 Ildar Akhmetgaleev 2017-02-23 03:52:00 UTC
Ca not reproduce anymore. Closing.


Note You need to log in before you can comment on or make changes to this bug.