Bug 1422887 - Get 503 error when Panko API request includes X-Auth-token
Summary: Get 503 error when Panko API request includes X-Auth-token
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Pradeep Kilambi
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-16 13:16 UTC by Marek Aufart
Modified: 2017-05-17 19:59 UTC (History)
5 users (show)

Fixed In Version: instack-undercloud-6.0.0-0.20170220135156.d695df8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:59:56 UTC


Attachments (Terms of Use)
details (7.22 KB, text/plain)
2017-02-16 13:16 UTC, Marek Aufart
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 434920 None None None 2017-02-16 16:19:31 UTC

Description Marek Aufart 2017-02-16 13:16:13 UTC
Created attachment 1250865 [details]
details

Description of problem:
Panko API fails with HTTP 503 error in case request contains Keystone token (X-Auth-Token).

Version-Release number of selected component (if applicable):
OSP11 deployed with infrared on Feb-15.

How reproducible:
always

Steps to Reproduce:
1. deploy OSP11 with infrared jenkins job with enabled telemetry
2. obtain keystone auth token
3. access Panko HTTP API with token from step 2

Actual results:
Get HTTP 503 error

Expected results:
Get valid JSON as a response

Additional info:

Comment 1 Marek Aufart 2017-02-16 14:23:59 UTC
Thanks pradk, sileth and yprokule for support, works on undercloud after manual applying https://review.openstack.org/#/c/434920/ and https://review.openstack.org/#/c/434925/

This BZ is from Cloudforms integration point of view a blocker.

Comment 4 errata-xmlrpc 2017-05-17 19:59:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.