Bug 1422905 - Upgrade from 6.1 -> 6.2 should update the :default_values_dir in the yaml
Summary: Upgrade from 6.1 -> 6.2 should update the :default_values_dir in the yaml
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.1.11
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-16 14:18 UTC by Andrew Kofink
Modified: 2018-09-04 17:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 17:46:02 UTC


Attachments (Terms of Use)

Description Andrew Kofink 2017-02-16 14:18:05 UTC
Description of problem:
After upgrading from 6.1, the /etc/foreman-installer/scenarios.d/satellite.yaml contains a value `:default_values_dir: /etc/katello-installer`. This value should be migrated to `:default_values_dir: /etc/foreman-installer/scenarios.d/satellite.yaml`.

Version-Release number of selected component (if applicable):
6.1

How reproducible:
Always

Steps to Reproduce:
1. Upgrade a satellite from 6.1 to 6.2
2. rm /etc/katello-installer
3. Try to run the installer

Actual results:
# satellite-installer --scenario satellite --upgrade
/usr/share/ruby/tmpdir.rb:85:in `mkdir': No such file or directory - /etc/katello-installer/d20170215-14026-zvmwwr (Errno::ENOENT)
        from /usr/share/ruby/tmpdir.rb:85:in `block in mktmpdir'
        from /usr/share/ruby/tmpdir.rb:142:in `create'
        from /usr/share/ruby/tmpdir.rb:85:in `mktmpdir'
        from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/configuration.rb:139:in `params_default_values'
        from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/configuration.rb:194:in `block in preset_defaults_from_puppet'
        from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/configuration.rb:193:in `each'
        from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/configuration.rb:193:in `preset_defaults_from_puppet'
        from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/kafo_configure.rb:251:in `set_parameters'
        from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/kafo_configure.rb:97:in `initialize'
        from /usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `new'
        from /usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `run'
        from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/kafo_configure.rb:148:in `run'
        from /usr/sbin/satellite-installer:12:in `<main>'

Expected results:
The installer runs successfully.

Additional info:
Found this bug when restoring a 6.2 backup of a machine that migrated from 6.1 to a 6.2 machine, which didn't contain the /etc/katello-installer directory. This directory seems to be left behind instead of removed on machines upgraded from 6.1 to 6.2.

Comment 2 Bryan Kearney 2017-09-14 17:00:25 UTC
Cleaning up the 6.2.z queue, pushing this to backlog for inclusion in a future release. Reviewed with CEE, QE, and ENG and pushed out due to low customer impact.

Comment 3 Mikel Olasagasti 2018-07-16 07:44:23 UTC
Same issue doing a restore with 6.2.15. System has been updated since 6.1.x:

(...)
yes | satellite-installer -v --reset --scenario satellite
/usr/share/ruby/tmpdir.rb:85:in `mkdir': No such file or directory -
/etc/katello-installer/d20180713-23247-voxhkc (Errno::ENOENT)
    from /usr/share/ruby/tmpdir.rb:85:in `block in mktmpdir'
    from /usr/share/ruby/tmpdir.rb:142:in `create'
    from /usr/share/ruby/tmpdir.rb:85:in `mktmpdir'
    from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/configuration.rb:139:in
`params_default_values'
    from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/configuration.rb:194:in
`block in preset_defaults_from_puppet'
    from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/configuration.rb:193:in
`each'
    from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/configuration.rb:193:in
`preset_defaults_from_puppet'
    from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/kafo_configure.rb:251:in
`set_parameters'
    from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/kafo_configure.rb:97:in
`initialize'
    from /usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `new'
    from /usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `run'
    from /usr/share/gems/gems/kafo-0.7.6.1/lib/kafo/kafo_configure.rb:148:in
`run'
    from /sbin/satellite-installer:12:in `<main>'
Failed 'yes | satellite-installer -v --reset --scenario satellite'

Upgrading to 6.3 keeps the default value:

# grep default_values_dir /etc/foreman-installer/scenarios.d/satellite.yaml
:default_values_dir: /etc/katello-installer

Comment 4 Bryan Kearney 2018-09-04 17:46:02 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.