Bug 142294 - a2ps default configuration is lacking
a2ps default configuration is lacking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: a2ps (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-08 15:09 EST by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 4.13b-43
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-09 11:40:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-12-08 15:09:16 EST
Description of problem:

In a default /etc/ap2s.cfg for "AppendLibraryPath" one can see:

/usr/local/ghostscript/fonts:/usr/local/share/ghostscript/fonts

which is not really right in the context.  As a result
'a2ps --list-options' produces:
....
  library path        = 
	/root/.a2ps
	/usr/share/a2ps/sheets
	/usr/share/a2ps/ps
	/usr/share/a2ps/encoding
	/usr/share/a2ps/afm
	/usr/share/ogonkify/afm
	/usr/share/a2ps/ppd
	/usr/share/a2ps/fonts
	/usr/share/ogonkify/fonts
	/usr/share/a2ps
	/usr/local/ghostscript/fonts
	/usr/local/share/ghostscript/fonts

and '/usr/share/a2ps/afm/make_fonts_map.sh' does not see many
useful fonts which most likely are on the system.

Here is a list of various directories found with .afm files
(that is what a2ps is looking for):

/usr/lib/ooo-1.1/share/psprint/fontmetric
/usr/share/a2ps/afm
/usr/share/enscript
/usr/share/fonts/afms/adobe
/usr/share/fonts/default/ghostscript
/usr/share/fonts/default/Type1
/usr/share/groff/1.18.1.1/font/devps/generate
/usr/share/libwmf/fonts
/usr/share/ogonkify/afm
/usr/share/texmf/fonts/afm/adobe/avantgar
/usr/share/texmf/fonts/afm/adobe/bookman
/usr/share/texmf/fonts/afm/adobe/courier
/usr/share/texmf/fonts/afm/adobe/helvetic
/usr/share/texmf/fonts/afm/adobe/ncntrsbk
/usr/share/texmf/fonts/afm/adobe/palatino
/usr/share/texmf/fonts/afm/adobe/symbol
/usr/share/texmf/fonts/afm/adobe/times
/usr/share/texmf/fonts/afm/adobe/zapfchan
/usr/share/texmf/fonts/afm/adobe/zapfding
/usr/share/texmf/fonts/afm/bitstrea/charter
/usr/share/texmf/fonts/afm/public/antp
/usr/share/texmf/fonts/afm/public/antt
/usr/share/texmf/fonts/afm/public/marvosym
/usr/share/texmf/fonts/afm/public/mathpazo
/usr/share/texmf/fonts/afm/public/omega
/usr/share/texmf/fonts/afm/public/pl
/usr/share/texmf/fonts/afm/public/pxfonts
/usr/share/texmf/fonts/afm/public/qfonts
/usr/share/texmf/fonts/afm/public/txfonts
/usr/share/texmf/fonts/afm/public/xypic
/usr/share/texmf/fonts/afm/urw/avantgar
/usr/share/texmf/fonts/afm/urw/bookman
/usr/share/texmf/fonts/afm/urw/courier
/usr/share/texmf/fonts/afm/urw/helvetic
/usr/share/texmf/fonts/afm/urw/ncntrsbk
/usr/share/texmf/fonts/afm/urw/palatino
/usr/share/texmf/fonts/afm/urw/symbol
/usr/share/texmf/fonts/afm/urw/times
/usr/share/texmf/fonts/afm/urw/zapfchan
/usr/share/texmf/fonts/afm/urw/zapfding
/usr/share/texmf/fonts/afm/yandy/lubright
/usr/share/texmf/fonts/afm/yandy/lucida
/usr/share/texmf/fonts/afm/yandy/lucidfax
/usr/share/texmf/fonts/afm/yandy/lucsans
/usr/share/texmf/fonts/afm/yandy/lumath
/usr/share/texmf/fonts/afm/yandy/mathplus
/usr/share/texmf/fonts/afm/yandy/mathtime
/usr/X11R6/lib/X11/fonts/Type1

Even after dropping "yandy" from that list, and possibly few
others, this still leaves quite a number which look much more
useful than /usr/local/ghostscript/fonts.

Version-Release number of selected component (if applicable):
a2ps-4.13b-42
Comment 1 Michal Jaegermann 2004-12-09 10:48:51 EST
I am not sure about that but it seems that metrics only may be not
good enough and a2ps makes a tacit assumption that a font file will
be found in the same directory as its metric - which may or may not
be true.  Last night I rewrote myself make_fonts_map.sh script to
add a font to a map file only if both some_name.afm and
some_name.pf[abm] are found somewhere in a declared path (with an
exception of a2ps directories on a hope that a2ps knows what it is
doing; which may be too optimistic).  Are you interested?

Metrics only should be good enough in a case of "standard fonts".
These will be provided by Postscript printers and for other
ghostscript will make a substitution as needed.
Comment 2 Tim Waugh 2004-12-09 10:53:16 EST
I've really no idea about how that stuff works or is meant to work. :-(
Comment 3 Michal Jaegermann 2004-12-09 11:00:13 EST
Well, at least 

/usr/share/fonts/default/ghostscript
/usr/share/fonts/default/Type1
/usr/X11R6/lib/X11/fonts/Type1

instead of

/usr/local/ghostscript/fonts
/usr/local/share/ghostscript/fonts

in a default configuration should give a better "standard" layout.
Comment 4 Tim Waugh 2004-12-09 11:21:06 EST
(changing to devel since FC3 has a2ps-4.13b-41 and has the correct paths listed.)
Comment 5 Tim Waugh 2004-12-09 11:26:51 EST
Problem was that the a2ps-4.13-conf.patch only touched configure but not
configure.in.
Comment 7 Michal Jaegermann 2004-12-09 18:59:24 EST
Yes, this was about "devel".  I listed a correct version but
failed to notice in bugzilla that not that branch was showing up.

OTOH my version of make_fonts_map.sh for some reasons finds on
FC3 installation, and without touching anything in /etc/a2ps.cfg,
thirty five more fonts than what shows up in a provided
/usr/share/a2ps/afm/fonts.map

Note You need to log in before you can comment on or make changes to this bug.