Bug 142301 - mDNSResponder goes into uninterruptible sleep on suspend-resume
mDNSResponder goes into uninterruptible sleep on suspend-resume
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: howl (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-08 16:01 EST by Alistair Riddoch
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-10 21:00:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alistair Riddoch 2004-12-08 16:01:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
On a laptop system using ACPI, the mDNSResponder daemon frequently
goes into a state where it shows up top in "uninterruptible sleep"
state signified by "D" in the S column. This seems to occur when the
laptop has suspended and resumed, and once it occurs the system will
no longer suspend, and mDNSResponder cannot be killed. The laptop
is being suspended using the "mem" method of /sys/power/state.

Version-Release number of selected component (if applicable):
howl-0.9.6-6 kernel-2.6.9-1.681_FC3

How reproducible:
Sometimes

Steps to Reproduce:
1. Boot the system running mDNSResponder
2. Suspend the system repeatedly

Actual Results:  The system will fail to suspend giving an error
message about mDNSResponder. The init script will not be able to stop
mDNSResponder. Kill will not work on mDNSResponder. mDNSResponder
shows up in a process list as in "uninterruptible sleep" state.

Expected Results:  The system should suspend cleanly, and
mDNSResponder should shutdown when killed.
Comment 1 Alexander Larsson 2004-12-08 22:32:57 EST
This really sounds like a kernel issue. Processes in D state are
waiting  in the kernel for some device-related issue. All
mDNSResponder does is send and receive ip broadcasts and talk to
clients over unix domain sockets.
Comment 2 Alistair Riddoch 2004-12-09 05:48:55 EST
Yes. I filed it under howl because that is where the bug manifests,
and included the kernel version in the report.
Comment 3 Alan Shutko 2005-01-17 09:45:39 EST
I see this problem as well, and it currently occurs for me with kernel
2.6.10-1.741_FC3.  The first thing that happens for me is that I
attempt to suspend the computer, and mDNSResponder does not stop, and
the system is not suspended.  

If I kill mDNSResponder before suspending, or stop it from starting, I
see no problems.  It may be a kernel issue, but mDNSResponder is
certainly the trigger.
Comment 4 Yaron Minsky 2005-01-27 20:53:38 EST
I get the same issue, running on 2.6.10-1.741_FC3 on a Thinkpad T21
laptop.  Once this happens, there's no killing the mDNSResponder
process ("service mDNSResponder stop" doesn't work.)  The only
solution I've found is to reboot. 
Comment 5 Alexander Larsson 2005-02-10 03:43:43 EST
I think there is a way to find out where in the kernel the process is
blocking. Can anyone try to figure that out and report back here?
Comment 6 petrosyan 2005-06-16 13:16:36 EDT
This bug has been fixed in Fedora Core 4.
Comment 7 Alistair Riddoch 2005-11-30 05:20:30 EST
I no longer see this problem, and as far as I am concerned the bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.