Bug 142308 - IPv6 default route needs to be changed according to RFC 3587
Summary: IPv6 default route needs to be changed according to RFC 3587
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-08 21:52 UTC by Peter Bieringer
Modified: 2014-03-17 02:51 UTC (History)
1 user (show)

Fixed In Version: 8.02-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 23:04:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for network-functions-ipv6 to change default route (1.57 KB, patch)
2004-12-08 21:55 UTC, Peter Bieringer
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:124 normal SHIPPED_LIVE initscripts bug fix update 2005-06-09 04:00:00 UTC

Description Peter Bieringer 2004-12-08 21:52:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.7.3)
Gecko/20040922

Description of problem:
(My) current version of network-functions-ipv6 uses 2000::/3 as
default route because of historic issue, when older Linux kernel don't
support manual setup of ::/0 as default route.

Times have changed, now it looks like that at least the newest kernel
of Fedora Core 1 and 2 support this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. setup IPv6 with a default route via initscripts
    

Actual Results:  Default route is 2000::/3

Expected Results:  Default route should be ::/0

Comment 1 Peter Bieringer 2004-12-08 21:55:25 UTC
Created attachment 108152 [details]
Patch for network-functions-ipv6 to change default route

Comment 2 Bill Nottingham 2004-12-08 23:04:11 UTC
Added (minus some of the commenting). Will be in 8.02-1.
Also added to FC3, RHEL4, FC2 branches... will be in future builds of
those, if they happen.

Comment 3 Tim Powers 2005-06-09 12:34:11 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-124.html



Note You need to log in before you can comment on or make changes to this bug.