Bug 1423421 - java-1.8.0-openjdk: javadoc crashes on valid Java source
Summary: java-1.8.0-openjdk: javadoc crashes on valid Java source
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.8.0-openjdk
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Omair Majid
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-17 09:44 UTC by Mikolaj Izdebski
Modified: 2017-03-03 21:49 UTC (History)
6 users (show)

Fixed In Version: java-1.8.0-openjdk-1.8.0.121-8.b14.fc24 java-1.8.0-openjdk-1.8.0.121-8.b14.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-03 21:18:54 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Icedtea Bugzilla 3335 None None None 2017-03-03 07:03:50 UTC
openjdk bug system JDK-8061305 None None None 2017-03-03 06:57:55 UTC

Description Mikolaj Izdebski 2017-02-17 09:44:11 UTC
Description of problem:
javadoc crashes on valid Java source

Version-Release number of selected component (if applicable):
java-1.8.0-openjdk-devel-1.8.0.121-1.b14.fc25.x86_64

Steps to Reproduce:

$ cat Reproducer.java
public class Reproducer {
    public Object Property() { return null; }
}

$ javadoc Reproducer.java
Loading source file Reproducer.java...
Constructing Javadoc information...
Standard Doclet version 1.8.0_121
Building tree for all the packages and classes...
Generating ./Reproducer.html...
java.lang.StringIndexOutOfBoundsException: String index out of range: 0
	at java.lang.String.charAt(String.java:658)
	at com.sun.tools.doclets.internal.toolkit.util.VisibleMemberMap$ClassMembers.getterForField(VisibleMemberMap.java:607)
	at com.sun.tools.doclets.internal.toolkit.util.VisibleMemberMap$ClassMembers.properties(VisibleMemberMap.java:552)
	at com.sun.tools.doclets.internal.toolkit.util.VisibleMemberMap$ClassMembers.getClassMembers(VisibleMemberMap.java:467)
	at com.sun.tools.doclets.internal.toolkit.util.VisibleMemberMap$ClassMembers.addMembers(VisibleMemberMap.java:372)
	at com.sun.tools.doclets.internal.toolkit.util.VisibleMemberMap$ClassMembers.mapClass(VisibleMemberMap.java:346)
	at com.sun.tools.doclets.internal.toolkit.util.VisibleMemberMap$ClassMembers.build(VisibleMemberMap.java:341)
	at com.sun.tools.doclets.internal.toolkit.util.VisibleMemberMap$ClassMembers.access$100(VisibleMemberMap.java:291)
	at com.sun.tools.doclets.internal.toolkit.util.VisibleMemberMap.<init>(VisibleMemberMap.java:127)
	at com.sun.tools.doclets.internal.toolkit.builders.MemberSummaryBuilder.<init>(MemberSummaryBuilder.java:82)
	at com.sun.tools.doclets.internal.toolkit.builders.MemberSummaryBuilder.getInstance(MemberSummaryBuilder.java:101)
	at com.sun.tools.doclets.internal.toolkit.builders.BuilderFactory.getMemberSummaryBuilder(BuilderFactory.java:278)
	at com.sun.tools.doclets.formats.html.ClassWriterImpl.getNavSummaryLinks(ClassWriterImpl.java:641)
	at com.sun.tools.doclets.formats.html.ClassWriterImpl.addSummaryDetailLinks(ClassWriterImpl.java:622)
	at com.sun.tools.doclets.formats.html.HtmlDocletWriter.addNavLinks(HtmlDocletWriter.java:560)
	at com.sun.tools.doclets.formats.html.ClassWriterImpl.getHeader(ClassWriterImpl.java:165)
	at com.sun.tools.doclets.internal.toolkit.builders.ClassBuilder.buildClassDoc(ClassBuilder.java:145)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at com.sun.tools.doclets.internal.toolkit.builders.AbstractBuilder.invokeMethod(AbstractBuilder.java:187)
	at com.sun.tools.doclets.internal.toolkit.builders.AbstractBuilder.build(AbstractBuilder.java:135)
	at com.sun.tools.doclets.internal.toolkit.builders.ClassBuilder.build(ClassBuilder.java:120)
	at com.sun.tools.doclets.formats.html.HtmlDoclet.generateClassFiles(HtmlDoclet.java:189)
	at com.sun.tools.doclets.internal.toolkit.AbstractDoclet.generateClassFiles(AbstractDoclet.java:207)
	at com.sun.tools.doclets.internal.toolkit.AbstractDoclet.generateClassFiles(AbstractDoclet.java:191)
	at com.sun.tools.doclets.internal.toolkit.AbstractDoclet.startGeneration(AbstractDoclet.java:139)
	at com.sun.tools.doclets.internal.toolkit.AbstractDoclet.start(AbstractDoclet.java:82)
	at com.sun.tools.doclets.formats.html.HtmlDoclet.start(HtmlDoclet.java:80)
	at com.sun.tools.doclets.standard.Standard.start(Standard.java:39)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at com.sun.tools.javadoc.DocletInvoker.invoke(DocletInvoker.java:310)
	at com.sun.tools.javadoc.DocletInvoker.start(DocletInvoker.java:189)
	at com.sun.tools.javadoc.Start.parseAndExecute(Start.java:366)
	at com.sun.tools.javadoc.Start.begin(Start.java:219)
	at com.sun.tools.javadoc.Start.begin(Start.java:205)
	at com.sun.tools.javadoc.Main.execute(Main.java:64)
	at com.sun.tools.javadoc.Main.main(Main.java:54)
javadoc: error - String index out of range: 0
1 error

Comment 1 Omair Majid 2017-02-17 20:30:34 UTC
I can confirm the bug with our rpms.

I can not reproduce this with upstream OpenJDK 9-ea+154.

I can reproduce with the following upstream OpenJDK 8 versions:

- latest jdk8u 
- jdk8u111-b14
- jdk8u45-b37

I wasn't able to build jdk8-b132 to test that.

Comment 2 Omair Majid 2017-02-17 22:07:42 UTC
Looks like this is JDK-8061305:
https://bugs.openjdk.java.net/browse/JDK-8061305

Upstream fix is only in 9:
http://hg.openjdk.java.net/jdk9/jdk9/langtools/rev/9fd9a50e7994?revcount=20

Comment 3 Omair Majid 2017-02-17 22:51:25 UTC
Thanks for reporting this issue, Mikolaj. Are you looking to get this fixed in F26 or current releases as well?

Comment 4 Omair Majid 2017-02-21 03:38:01 UTC
Fixed in https://koji.fedoraproject.org/koji/buildinfo?buildID=860384

Comment 5 Mikolaj Izdebski 2017-02-21 22:02:44 UTC
(In reply to Omair Majid from comment #3)
> Thanks for reporting this issue, Mikolaj. Are you looking to get this fixed
> in F26 or current releases as well?

I have a workaround, so personally I don't need this fixed.

Comment 6 jiri vanek 2017-02-22 09:54:45 UTC
It will bubble to f25 by sync from rawhide sooner or later anyway.

Comment 7 Fedora Update System 2017-02-28 09:46:48 UTC
java-1.8.0-openjdk-1.8.0.121-8.b14.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f66b383735

Comment 8 Fedora Update System 2017-02-28 17:56:35 UTC
java-1.8.0-openjdk-1.8.0.121-8.b14.fc25 nss-3.28.3-1.0.fc25 nss-softokn-3.28.3-1.1.fc25 nss-util-3.28.3-1.0.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f66b383735

Comment 9 Fedora Update System 2017-03-01 02:54:03 UTC
java-1.8.0-openjdk-1.8.0.121-8.b14.fc25, nss-3.28.3-1.0.fc25, nss-softokn-3.28.3-1.1.fc25, nss-util-3.28.3-1.0.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f66b383735

Comment 10 Fedora Update System 2017-03-01 09:14:52 UTC
nss-3.28.3-1.0.fc24 nss-softokn-3.28.3-1.1.fc24 nss-util-3.28.3-1.0.fc24 java-1.8.0-openjdk-1.8.0.121-8.b14.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f22b7e0c19

Comment 11 Fedora Update System 2017-03-02 02:52:44 UTC
java-1.8.0-openjdk-1.8.0.121-8.b14.fc24, nss-3.28.3-1.0.fc24, nss-softokn-3.28.3-1.1.fc24, nss-util-3.28.3-1.0.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f22b7e0c19

Comment 12 Fedora Update System 2017-03-03 21:18:54 UTC
java-1.8.0-openjdk-1.8.0.121-8.b14.fc24, nss-3.28.3-1.0.fc24, nss-softokn-3.28.3-1.1.fc24, nss-util-3.28.3-1.0.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2017-03-03 21:49:51 UTC
java-1.8.0-openjdk-1.8.0.121-8.b14.fc25, nss-3.28.3-1.0.fc25, nss-softokn-3.28.3-1.1.fc25, nss-util-3.28.3-1.0.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.