Bug 142344 - php_config.h does not match php program
php_config.h does not match php program
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-08 21:20 EST by Pete Olson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-09 11:07:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Olson 2004-12-08 21:20:33 EST
Description of problem:
php_config.h contains the line
#define HAVE_GD_BUNDLED 1

However, running php -i indicates php was compiled --with-gd=shared

This results in linkage errors if compiling a downloadable php module
which also uses gd.

Version-Release number of selected component (if applicable):
php-4.3.9-3
php-devel-4,3.9-3

How reproducible:
Always

Steps to Reproduce:
1. Build a php downloadable module which uses gd. 
2.
3.
  
Actual results:
Linkage errors looking for the php internal gd routines

Expected results:
No errors.

Additional info:
Can be fixed by commenting out the above line in php_config.h, but
since that file is auto-generated it's only a temporary fix.
Comment 1 Joe Orton 2004-12-09 04:42:12 EST
"HAVE_GD_BUNDLED" means that the bundled copy of the libgd library was
used.

--with-gd=shared means that the gd extension was built as a shared
module, /usr/lib/php4/gd.so in this case.  What issue do you see with
what PHP extension? 
Comment 2 Pete Olson 2004-12-09 11:05:24 EST
I had some confusion about the meaning of --with-gd=shared, as it is
only documented as being either --with-gd or --with-gd=DIR.

So the problem is actually that gd.so is not in /usr/lib/php4, nor in
any of php-* rpms.  

I recompiled from the source rpm and gd.so does exist in the php-4.3.9
directory.

I guess it's a packaging problem.
Comment 3 Joe Orton 2004-12-09 11:07:20 EST
The gd extension is now packaged in the php-gd package, so if you have
upgraded from a previous release you will need to install php-gd to
restore the functionality.

This issue is covered in the FC3 release notes, FWIW.

Note You need to log in before you can comment on or make changes to this bug.