Bug 142351 - man(1) doesn't output Japanese characters normally in ja_JP.eucJP.
man(1) doesn't output Japanese characters normally in ja_JP.eucJP.
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: man (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-09 01:41 EST by L3support
Modified: 2010-10-21 22:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-21 04:06:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L3support 2004-12-09 01:41:56 EST
Description of problem:
man(1) doesn't output Japanese characters normally in ja_JP.eucJP locale.

Version-Release number of selected component (if applicable):
man-1.5m2-9

How reproducible:
always

Steps to Reproduce:
1. # export LANG=ja_JP.eucJP
2. set character encoding of terminal to Japanese EUC_JP.
3. # man ls
  
Actual results:
Japanese characters are garbled.

Expected results:
Japanese characters are output normally.

Additional info:
Comment 1 Eido Inoue 2004-12-10 14:45:42 EST
nroff is responsible for converting from legacy encodings (i.e.
EUC-JP) or UTF-8 to UTF-8. It does not currently convert to anything
but UTF-8.

At the time nroff was re-written to support this, we decided upwards
compatibility (the ability to use old and third party man pages)
written in non-Unicode was to be supported, but support for reverting
a system backwards to operate in legacy encodings was not necessary.

However, man has recently been modified to output its error messages
in legacy as well as modern UTF-8, so we may want to re-think this.

Anyway, component in the pipe chain that is responsible for converting
the man page encoding is nroff, so changing component.
Comment 2 L3support 2004-12-21 04:03:20 EST
PAGER's problem seems to be the casue of this issue.

nroff(1) seems to convert UTF-8 to the current locale encoding. So I
change the value of 'PAGER' in /etc/man.config from '/usr/bin/less
-iRs' to '/usr/bin/less -isr'. As a result, man(1) properly outputs
mulit-byte characters encoded with EUC-JP.

Could you change the value of PAGER in /etc/man.config?
Comment 3 RHEL4-L3support 2005-01-18 21:10:20 EST
Add RHEL4-L3support team in Japan
Comment 6 L3support 2005-02-24 02:40:12 EST
Refer to Issue 66087.

Note You need to log in before you can comment on or make changes to this bug.