Bug 1423542 - Include gdeploy preflight check
Summary: Include gdeploy preflight check
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: 0.10.7-0.0.6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ovirt-4.1.1
: 0.10.7-0.0.13
Assignee: Ramesh N
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2017-02-17 13:49 UTC by SATHEESARAN
Modified: 2017-04-21 09:45 UTC (History)
4 users (show)

Fixed In Version: cockpit-ovirt-0.10.7-0.0.11
Doc Type: Enhancement
Doc Text:
Gdeploy has a script to validate basic network setup and storage configuration before deploying Gluster. This script is now included in the generated gdeploy configuration for HyperConverged deployment so that users can deploy a cleaner HyperConverged environment.
Clone Of:
Environment:
Last Closed: 2017-04-21 09:45:55 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.1+
rule-engine: exception+
rule-engine: planning_ack+
rnachimu: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 72640 master MERGED gdeploy: include preflight check in generated gdeploy config 2017-02-21 16:32:09 UTC
oVirt gerrit 72799 ovirt-4.1 MERGED gdeploy: include preflight check in generated gdeploy config 2017-02-21 16:32:52 UTC

Description SATHEESARAN 2017-02-17 13:49:18 UTC
Description of problem:
-----------------------
gdeploy provides the script that checks for the following:
1. Whether the disks are GPT partitioned
2. Whether all the hosts are reachable from all other hosts

If any of the above condidion is false, gdeploy stops and doesn't proceeds
This preflight check should be added to the gdeploy configuration files generate by cockpit-gdeploy

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
cockpit-ovirt-dashboard-0.10.7-0.0.6

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
Not applicable

Actual results:
---------------
Preflight configuration check is not part of gdeploy configuration file generated by cockpit-gdeploy plugin

Expected results:
-----------------
Preflight configuration check should be part of gdeploy configuration file generated by cockpit-gdeploy plugin

Additional info:
-----------------
This configuration check is available with gdeploy-2.0.1-11.el7rhgs with effect of the bug - https://bugzilla.redhat.com/show_bug.cgi?id=1405447

Gdeploy config would go like this:

[script1]
action=execute
file=/usr/share/ansible/gdeploy/scripts/grafton-sanity-check.sh -d sdb,sdc -h host1,host2,host3
ignore_script_errors=no

Comment 1 Ramesh N 2017-02-19 17:13:57 UTC
I have added following section to the generated gdeploy configuration.

[script1]
action=execute
file=/usr/share/gdeploy/scripts/grafton-sanity-check.sh
ignore_script_errors=no

sac: Do we need to pass the host names and disk names explicitly to this script or gdeploy will figure out those details since it is available in other sections?. I am not seeing these values explicitly passed in sample config at https://github.com/gluster/gdeploy/blob/master/examples/hc.conf. Also do we need to add ignore_script_errors=no? This is also not there in the sample config.

Comment 2 Sachidananda Urs 2017-02-20 07:04:50 UTC
The syntax is something like:

[script1]
action=execute
file=/usr/share/ansible/gdeploy/scripts/grafton-sanity-check.sh -d disk1,disk2 -h host1,host2
ignore_script_errors=no

I have committed example upstream: https://github.com/gluster/gdeploy/commit/73df3720b5c5

Comment 3 Ramesh N 2017-02-20 07:15:08 UTC
(In reply to Sachidananda Urs from comment #2)
> The syntax is something like:
> 
> [script1]
> action=execute
> file=/usr/share/ansible/gdeploy/scripts/grafton-sanity-check.sh -d
> disk1,disk2 -h host1,host2
> ignore_script_errors=no
> 
> I have committed example upstream:
> https://github.com/gluster/gdeploy/commit/73df3720b5c5

Thanks Sac for confirming. I have updated the patch with host and disk list.

Comment 4 SATHEESARAN 2017-03-07 10:32:28 UTC
Tested with cockpit-ovirt-0.10.7-0.0.11

gdeploy config file includes the check for disks and hosts.

[script1]
action=execute
ignore_script_errors=no
file=/usr/share/ansible/gdeploy/scripts/grafton-sanity-check.sh -d sdb -h host1,host2,host3


Note You need to log in before you can comment on or make changes to this bug.