Bug 142411 - nss-mdns provides link-local mDNS hostname lookups
nss-mdns provides link-local mDNS hostname lookups
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
http://0pointer.de/lennart/projects/n...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-09 11:42 EST by Will Woods
Modified: 2014-03-16 22:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 17:35:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a specfile for nss-mdns (1.17 KB, text/plain)
2004-12-09 11:45 EST, Will Woods
no flags Details

  None (edit)
Description Will Woods 2004-12-09 11:42:33 EST
Fedora already ships with mDNSResponder (part of howl) which can
respond to mDNS queries. That corresponds to the server portion of a
normal DNS setup. nss-mdns is an NSS plugin that adds the
corresponding client code to glibc.

With this package installed and configured properly (all I had to do
was add 'mdns4' to the hosts: line in nsswitch.conf) machines can
refer to each other by name even in the absense of a DNS server,
either with valid DHCP-assigned IP addresses or self-assigned
(Zeroconf/IPv4LL) addresses. I've tried it with two linux boxes and a
Mac, both on a private and public network.

This feature is a part of Apple's Rendezvous technology (giving better
Mac interoperability) and would also make running home/small office
networks a lot easier (no DNS server needed! Plug in a new machine or
a laptop and instantly refer to it by its name!)
Comment 1 Will Woods 2004-12-09 11:45:25 EST
Created attachment 108226 [details]
a specfile for nss-mdns

I guessed on the Group. It doesn't modify nsswitch.conf, but I don't know how
that should be done.
Comment 2 Bill Nottingham 2004-12-09 12:30:23 EST
authconfig is normally what modifies nsswitch.conf.

Want to maintain nss-mdns? >:)
Comment 3 Bill Nottingham 2005-03-02 17:16:57 EST
Uli, is there planned to be any mDNS work in glibc directly that would conflict
with this, or is a new nss module the way to go?
Comment 4 Ulrich Drepper 2005-03-02 17:24:21 EST
The approach taken by the current nss-mdns is wrong.  The problem is that the
broadcasted results are not used.  The result is that the network is flooded
with unnecessary requests.

I talked to the author some time back and he acknoledged this.  He said he is
currently writing a program similar to the nDNSresponder which then will also
listen for the broadcast traffic and be able to answer requests from the
nss-mdns module.

Without this functionality the nss-mdns module is dangerous if you have more
than a couple of machines.

I'm not sure whether I trust the author to make all the changes in a timely
manner.  If not, I'll add appropriate code myself.  Until it is resolved one way
or another, we should not provide any half-cooked mdns support.
Comment 5 Bill Nottingham 2005-03-02 17:35:20 EST
OK. Deferring, then.

Note You need to log in before you can comment on or make changes to this bug.