Bug 142435 - panic after several hours, netplugd
panic after several hours, netplugd
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-09 13:42 EST by Michael Carney
Modified: 2015-01-04 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-13 15:01:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Carney 2004-12-09 13:42:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Kernel panics regularly after several hours (less than one day), when
the machine is not in use. Since the screen is blank, the only
indication of the panic is flashing caps/scroll lock keys.

Same behavior seen in 667 and 673.

I notice the following as the last entry in /var/log/messages before
the panic:

Dec  9 04:33:09 lucy-01 netplugd[2459]: eth0: state ACTIVE flags
0x00001043 UP,BROADCAST,RUNNING,MULTICAST -> 0x00001003
UP,BROADCAST,MULTICAST
Dec  9 04:33:09 lucy-01 netplugd[8189]: /etc/netplug.d/netplug eth0
out -> pid 8189
Dec  9 04:33:09 lucy-01 netplugd[2459]: eth0: state OUTING flags
0x00001003 UP,BROADCAST,MULTICAST -> 0x00001002 BROADCAST,MULTICAST
Dec  9 04:33:09 lucy-01 netplugd[2459]: eth0: state DOWNANDOUT pid
8189 exited status 0
Dec  9 04:33:09 lucy-01 netplugd[8232]: /etc/netplug.d/netplug eth0
probe -> pid 8232
Dec  9 04:33:09 lucy-01 netplugd[2459]: eth0: state PROBING flags
0x00001002 BROADCAST,MULTICAST -> 0x00001043
UP,BROADCAST,RUNNING,MULTICAST
Dec  9 04:33:09 lucy-01 netplugd[2459]: eth0: state PROBING_UP pid
8232 exited status 0

The above netplugd output doesn't occur when running with a single
processor (nor does the panic).

Version-Release number of selected component (if applicable):
2.6.9-1.681_FC3smp

How reproducible:
Always

Steps to Reproduce:
1.Boot to level 5
2.Log in
3.Wait.
    

Actual Results:  System panics

Expected Results:  Don't panic

Additional info:

This problem does not occur if I disable the second processor. Thus,
seems to be MT-related. Whether hyperthreading is enabled or not
doesn't seem to matter.

Machine is a Dell Workstation 530n, with 2 x Xeon 2Ghz, 1GB memory, 1
40GB IDE disk, a 18GB U160 SCSI disk hosting FC3, and a 73GB U160 SCSI
disk w/ data. A nightly dump (/sbin/dump) occurs to a DDS4 scsi tape
drive (always succeeds, finishes in a few minutes after 2am). The IDE
disk running, but not mounted. The scsi controller is an Adaptec 29160
add-on card. Onboard scsi is disabled.

19> lspci
00:00.0 Host bridge: Intel Corp. 82860 860 (Wombat) Chipset Host
Bridge (MCH) (rev 04)
00:01.0 PCI bridge: Intel Corp. 82850 850 (Tehama) Chipset AGP Bridge
(rev 04)
00:02.0 PCI bridge: Intel Corp. 82860 860 (Wombat) Chipset AGP Bridge
(rev 04)
00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 04)
00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 04)
00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 04)
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 04)
00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 04)
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 04)
00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97
Audio (rev 04)
01:00.0 VGA compatible controller: nVidia Corporation NV11GL [Quadro2
MXR/EX] (rev b2)
02:1f.0 PCI bridge: Intel Corp. 82806AA PCI64 Hub PCI Bridge (rev 03)
03:00.0 PIC: Intel Corp. 82806AA PCI64 Hub Advanced Programmable
Interrupt Controller (rev 01)
03:0c.0 SCSI storage controller: Adaptec AIC-7892A U160/m (rev 02)
04:0b.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado]
(rev 78)
20>

I'm running the userland nv display driver.
Comment 1 Dave Jones 2004-12-09 15:15:14 EST
can you disable the screen blanking to try and capture the panic ?
Comment 2 Michael Carney 2005-02-13 14:54:13 EST
I've gone on to later kernels (760 lately), and am now using nvidia's driver.
I'm not (and haven't) experienced this panic for some time now, so apparently
this problem no exists. Go ahead and close it.

Note You need to log in before you can comment on or make changes to this bug.