This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 142455 - s-c-d does not work at all if multiple heads are used with one card
s-c-d does not work at all if multiple heads are used with one card
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-09 15:19 EST by Ulrich Drepper
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.0.37-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-27 13:33:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2004-12-09 15:19:55 EST
Description of problem:
I have an nvidia quadro which allows running multiple heads off of one card. 
The card detection in the multihead tab shows no second card.  Therefore on exit
of s-c-d it prints:

Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 200, in ok
    if card.getCardData()["NAME"] ==
self.secondVideocardOptionMenu.get_menu().get_active().get_data("NAME"):
AttributeError: 'NoneType' object has no attribute 'get_data'


Version-Release number of selected component (if applicable):
system-config-display-1.0.24-1

How reproducible:
always

Steps to Reproduce:
1.get card with support for more than one head
2.run s-c-d
3.
  
Actual results:
error above

Expected results:
nice, usable config file

Additional info:
The card in question is

01:00.0 VGA compatible controller: nVidia Corporation NV37GL [Quadro FX 330]
(rev a2)
Comment 1 Sammy 2004-12-16 10:52:46 EST
Same here with Radeon 7000 
Comment 2 Ulrich Drepper 2006-05-27 13:33:38 EDT
This specific problem seems to be gone in FC5.  Whether it all works correctly I
haven't tested (I don't want to lose my configuration) but at least the second
head can be enabled in the GUI.

Note You need to log in before you can comment on or make changes to this bug.