Bug 142457 - kernel BUG is e1000_reset_hw
kernel BUG is e1000_reset_hw
Status: CLOSED DUPLICATE of bug 142456
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-09 15:28 EST by satish
Modified: 2013-08-05 21:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-09 16:48:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description satish 2004-12-09 15:28:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9)
Gecko/20020408

Description of problem:
I have a application which writes a lot of data in to a network based
filesystem. After a while we hit a hard hang. This is seen only on
e1000 driver. When i use tg3 i do not see the hard hang
I am using a 2.4.18.e-12smp kernel

<6> Netdev
<4> kernel BUG at e1000-hw.c:146
<4> swapper[0]: Nat consumption 8589934624
<4> e1000_reset_hw[1000] + 0x1d0 <---

show_stack
showa_regs
die
die_if_kernel
ia64_fault

Is there any workaround patch that are available for e1000. I tried
with the latest version on e1000 ie 5.5 and still see the hang

Version-Release number of selected component (if applicable):
4.3.9-k1

How reproducible:
Always

Steps to Reproduce:
1. Run the test porgram which pumps a lot of date in to the e1000 driver
2.
3.
    

Actual Results:  Machine hangs due to Kernel BUG

Expected Results:  work fine

Additional info:
Comment 1 Rik van Riel 2004-12-09 15:53:11 EST

*** This bug has been marked as a duplicate of 142456 ***
Comment 2 Ernie Petrides 2004-12-09 16:37:44 EST
This is not properly a dup because the releases are different
(and we need a separate bugzilla for each release for tracking
and Errata System purposes).
Comment 3 Ernie Petrides 2004-12-09 16:48:11 EST
Oops, my mistake.  Both of these were against RHEL2.1/ia64, so
reclosing this one as a dup.  (Sorry about that.)


*** This bug has been marked as a duplicate of 142456 ***

Note You need to log in before you can comment on or make changes to this bug.