Bug 1424761 - Freeze when rescanning for devices
Summary: Freeze when rescanning for devices
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gscan2pdf
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: https://sourceforge.net/p/gscan2pdf/b...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-19 09:33 UTC by Till Hofmann
Modified: 2017-04-01 16:58 UTC (History)
3 users (show)

Fixed In Version: gscan2pdf-1.7.3-1.fc25 gscan2pdf-1.7.3-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-21 22:55:41 UTC


Attachments (Terms of Use)

Description Till Hofmann 2017-02-19 09:33:09 UTC
Description of problem:
Rescanning for devices leads to the application being completely frozen, with 100% CPU load.

Version-Release number of selected component (if applicable):
1.7.2-1

How reproducible:
always

Steps to Reproduce:
1. Start application
2. Click on "Scan document"
3. Select "Rescan for devices"

Actual results:
The application freezes with a 100% CPU load after the scan completed.

Expected results:
No freeze.

Additional info:
This issue does not occur with 1.7.1

Comment 1 Petr Pisar 2017-02-20 10:22:09 UTC
I played with Fedora 26 and I could not reproduce your the CPU hog, but I can confirm it behaves weird. First it was fine, then the Scan window appeared blank, and now I do not get any Scan window when clicking on the Scan icon. And all of that regardless of gscan2psd version. I can also see "which" zombie processes.

I also remember sane libraries were updated some time ago. Maybe this is the reason.

Comment 2 Petr Pisar 2017-02-21 16:51:22 UTC
I tried Fedora 25 and I cannot reproduce it. The only issue is if no scanner is available, then Scan window usually cannot be invoked. Could please get in touch with gscan2pdf author at <https://sourceforge.net/p/gscan2pdf/bugs/240/>? He got similar bug report, but he also cannot reproduce it.

Comment 3 Fedora Update System 2017-03-13 08:46:13 UTC
gscan2pdf-1.7.3-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-b33a1277a9

Comment 4 Fedora Update System 2017-03-13 08:46:49 UTC
gscan2pdf-1.7.3-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-10617ce268

Comment 5 Fedora Update System 2017-03-14 01:23:08 UTC
gscan2pdf-1.7.3-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-10617ce268

Comment 6 Fedora Update System 2017-03-14 03:20:47 UTC
gscan2pdf-1.7.3-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-b33a1277a9

Comment 7 Fedora Update System 2017-03-21 22:55:41 UTC
gscan2pdf-1.7.3-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2017-04-01 16:58:55 UTC
gscan2pdf-1.7.3-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.