Bug 142484 - new feature: exclude packages for "up2date -p"
new feature: exclude packages for "up2date -p"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
https://www.redhat.com/archives/taroo...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-09 17:42 EST by John Vasileff
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:11:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Vasileff 2004-12-09 17:42:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
When rhn_register is initially run, there is an option to exclude
packages from the package profile stored on RHN.  However, a similar
option does not exist when performing system maintenance with "update
-p".  This can cause problems when RPMs are manually added or removed
from a system and it is desired to exclude some (other) package(s)
from RHN updates.

A discussion of this issue on the taroon-list can be found at:
https://www.redhat.com/archives/taroon-list/2004-December/msg00166.html

A workaround was discovered, but it is akward:

# Start: RHN shows updates required due to mod_ssl package
$ rpm -e --justdb mod_ssl
$ up2date -p
Updating package profile...
Updating transaction history...
# RHN now shows system is current
$ rpm -i --justdb mod_ssl-2.8.12-6.i386.rpm
# Test result of previous command
$ touch /var/www/html/manual/mod/mod_ssl/ssl_faq.html
$ rpm -qV mod_ssl
.......T   /var/www/html/manual/mod/mod_ssl/ssl_faq.html

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start with RHN reporting system is up2date
2. run 'up2date -p'
3. RHN now shows system is out-of-date despite sysadmin preferences to
skip package.
    

Additional info:
Comment 1 Ken Snider 2004-12-09 20:23:25 EST
This is a bug as much as an enhancement; Packages you exclude from
your system profile reappear if you do an up2date -p (or schedule a
package refresh). There is no way to prevent this.
Comment 2 RHEL Product and Program Management 2007-10-19 15:11:42 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.