Bug 1425005 - MIX version (BC) fails to deploy Newton overcloud from Ocata undercloud - Keystone API failures
Summary: MIX version (BC) fails to deploy Newton overcloud from Ocata undercloud - Key...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates-compat
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 11.0 (Ocata)
Assignee: mathieu bultel
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-20 11:09 UTC by Raviv Bar-Tal
Modified: 2017-05-17 20:00 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-heat-templates-compat-5.2.0-7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:00:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Raviv Bar-Tal 2017-02-20 11:09:26 UTC
Description of problem:
When trying to deploy new Newton overcloud from Ocata undercloud deployment fails.
below is the out put of 'openstack stack  failures list overcloud' command:

overcloud.AllNodesDeploySteps.ControllerDeployment_Step3.0:
  resource_type: OS::Heat::StructuredDeployment
  physical_resource_id: c371c74e-3b6a-4ee6-bdb1-6f58e2fc3f8d
  status: CREATE_FAILED
  status_reason: |
    Error: resources[0]: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 6
  deploy_stdout: |
    ...
    Notice: /Firewall[998 log all]: Dependency Keystone_tenant[admin] has failures: true
    Notice: /Firewall[998 log all]: Dependency Keystone_role[admin] has failures: true
    Notice: /Firewall[998 log all]: Dependency Keystone_user[admin] has failures: true
    Notice: /Firewall[998 log all]: Dependency Keystone_service[keystone::identity] has failures: true
    Notice: /Firewall[999 drop all]: Dependency Keystone_tenant[service] has failures: true
    Notice: /Firewall[999 drop all]: Dependency Keystone_tenant[admin] has failures: true
    Notice: /Firewall[999 drop all]: Dependency Keystone_role[admin] has failures: true
    Notice: /Firewall[999 drop all]: Dependency Keystone_user[admin] has failures: true
    Notice: /Firewall[999 drop all]: Dependency Keystone_service[keystone::identity] has failures: true
    Notice: Finished catalog run in 1334.66 seconds
    (truncated, view all with --long)
  deploy_stderr: |
    ...
    Error: Not managing Keystone_service[keystone] due to earlier Keystone API failures.
    Error: /Stage[main]/Keystone::Endpoint/Keystone::Resource::Service_identity[keystone]/Keystone_service[keystone::identity]/ensure: change from absent to present failed: Not managing Keystone_service[keystone] due to earlier Keystone API failures.
    Error: Could not prefetch keystone_endpoint provider 'openstack': Execution of '/usr/bin/openstack endpoint list --quiet --format csv' returned 1: __init__() got an unexpected keyword argument 'bind_address' (HTTP 400) (Request-ID: req-0ebb1593-b15b-40fd-b87b-508d09600014) (tried 49, for a total of 170 seconds)
    Warning: /Stage[main]/Keystone::Endpoint/Keystone::Resource::Service_identity[keystone]/Keystone_endpoint[regionOne/keystone::identity]: Skipping because of failed dependencies
    Error: /Stage[main]/Cinder::Db::Sync/Exec[cinder-manage db_sync]: Failed to call refresh: cinder-manage  db sync returned 1 instead of one of [0]
    Error: /Stage[main]/Cinder::Db::Sync/Exec[cinder-manage db_sync]: cinder-manage  db sync returned 1 instead of one of [0]
    Error: /Stage[main]/Heat::Db::Sync/Exec[heat-dbsync]: Failed to call refresh: heat-manage --config-file /etc/heat/heat.conf db_sync returned 1 instead of one of [0]
    Error: /Stage[main]/Heat::Db::Sync/Exec[heat-dbsync]: heat-manage --config-file /etc/heat/heat.conf db_sync returned 1 instead of one of [0]
    Warning: /Firewall[998 log all]: Skipping because of failed dependencies
    Warning: /Firewall[999 drop all]: Skipping because of failed dependencies
    (truncated, view all with --long)

Version-Release number of selected component (if applicable):


How reproducible:
install new Ocata undercloud 

Steps to Reproduce:
1. replace Ocata overcloudfull images with Netwon images
2. install the "compat" package for Netwon templates ( openstack-tripleo-heat-templates)
3. In the deploy command use Netown templates (--templates /usr/share/openstack-tripleo-heat-templates/newton/)

Actual results:
Deployment fails 

Expected results:
Deployment pass

Additional info:

Comment 1 mathieu bultel 2017-03-17 13:36:11 UTC
Hi Raviv,

Thank you for having gave me a reproducible deployment.
So it seems that the issue is due to the tht/compat dir which is not in phase with the tht package from the OSP 10 latest puddle.
I looks like the compat dir is a clone of upstream stable/newton.
So it probably miss some special cooks for OSP.
I'll dig a big more, I have dump all the diff between the both package in ~/matbu/diff on the environment.

Comment 2 Sofer Athlan-Guyot 2017-03-21 16:19:46 UTC
Hi Raviv,

that should work with the package mentioned.

Comment 3 Amit Ugol 2017-03-23 19:37:52 UTC
(In reply to Sofer Athlan-Guyot from comment #2)
> Hi Raviv,
> 
> that should work with the package mentioned.

But it does not according to latest testing. Perhaps something else was missing in the latest puddle.

Comment 4 mathieu bultel 2017-03-27 11:04:36 UTC
Hi Raviv Amit,

I test the latest puddle, the compat directory works fine:
 rpm -qa | grep tripleo-heat-templates
openstack-tripleo-heat-templates-compat-5.2.0-7.el7ost.noarch
openstack-tripleo-heat-templates-6.0.0-0.3.0rc2.el7ost.noarch

Comment 6 errata-xmlrpc 2017-05-17 20:00:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.