Bug 1425022 - Make registry-console optional, provide node selector
Summary: Make registry-console optional, provide node selector
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Vadim Rutkovsky
QA Contact: Johnny Liu
URL:
Whiteboard:
: 1548984 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-20 12:07 UTC by Marko Myllynen
Modified: 2018-08-08 03:11 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:08:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:09:27 UTC
Red Hat Bugzilla 1548984 None CLOSED [RFE] Predefined nodeselector Variable for registry-console 2019-05-29 03:34:47 UTC

Internal Links: 1548984

Description Marko Myllynen 2017-02-20 12:07:50 UTC
Description of problem:
registry-console is not needed in all cases (e.g. when embedding OpenShift), please consider making registry-console installation optional. Also, registry-console should have node selector (or at least it should go by default to the nodes where registries are being scheduled).

Comment 3 Eduardo Minguez 2017-06-29 15:25:31 UTC
As a workaround, in a post-install task you can run oc patch as:

oc patch dc registry-console -p '{"spec":{"template":{"spec":{"nodeSelector":{"role":"infra"}}}}}'

Comment 10 Marko Myllynen 2017-08-28 10:29:28 UTC
I'm reopening this for re-evaluation on the basis that a) we have most of the other components optional already, b) implementing this should be relatively straightforward, c) having this kind of one-off case is not consistent with the overall installer experience and might even create a bad precedence. However, if still deemed WONTFIX I won't insist keeping this open after that. Thanks.

Comment 11 Brenton Leanhardt 2017-08-28 14:04:03 UTC
Thanks Marko.  I saw that Scott already reached to product management to confirm we can make it optional.

Comment 13 Sergi Jimenez Romero 2017-12-15 11:35:08 UTC
(In reply to Brenton Leanhardt from comment #11)
> Thanks Marko.  I saw that Scott already reached to product management to
> confirm we can make it optional.

Brenton, was there any conclusion about it that you could share with us?

Thanks.

Comment 14 Scott Dodson 2017-12-15 13:53:29 UTC
PM has said that we're fine to make it optional. It's a trivial change that we'd welcome a PR for. :-)

Comment 16 Clayton Coleman 2018-03-26 03:40:39 UTC
In 3.10 registry console will go to the master nodes in all scenarios.  For making it optional, please submit a PR and I'll help review it and get it in.

Comment 17 Scott Dodson 2018-05-02 18:17:46 UTC
*** Bug 1548984 has been marked as a duplicate of this bug. ***

Comment 18 Vadim Rutkovsky 2018-06-14 15:08:02 UTC
Created https://github.com/openshift/openshift-ansible/pull/8766

Comment 19 Vadim Rutkovsky 2018-06-14 15:12:31 UTC
registry-console deployment is on by default, but can be disabled by setting 'openshift_hosted_manage_registry_console=false'

Comment 21 Johnny Liu 2018-06-19 09:14:04 UTC
Verified this bug with openshift-ansible-3.10.1-1.git.157.2bb6250.el7.noarch, and PASS.

Set openshift_hosted_manage_registry_console=false, run installation, registry-console is not deployed now.

PLAY [Create Hosted Resources - cockpit-ui] ************************************

TASK [Gathering Facts] *********************************************************
Tuesday 19 June 2018  04:28:17 -0400 (0:00:00.044)       0:15:03.655 ********** 
ok: [qe-jialiu310-master-etcd-1.0619-fv4.qe.rhcloud.com]

TASK [cockpit-ui : fetch the docker-registry route] ****************************
Tuesday 19 June 2018  04:28:19 -0400 (0:00:01.168)       0:15:04.824 ********** 
skipping: [qe-jialiu310-master-etcd-1.0619-fv4.qe.rhcloud.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}

TASK [cockpit-ui : Create passthrough route for registry-console] **************
Tuesday 19 June 2018  04:28:19 -0400 (0:00:00.031)       0:15:04.855 ********** 
skipping: [qe-jialiu310-master-etcd-1.0619-fv4.qe.rhcloud.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}

TASK [cockpit-ui : Create temp directory for kubeconfig] ***********************
Tuesday 19 June 2018  04:28:19 -0400 (0:00:00.032)       0:15:04.888 ********** 
skipping: [qe-jialiu310-master-etcd-1.0619-fv4.qe.rhcloud.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}

TASK [cockpit-ui : set_fact] ***************************************************
Tuesday 19 June 2018  04:28:19 -0400 (0:00:00.033)       0:15:04.921 ********** 
skipping: [qe-jialiu310-master-etcd-1.0619-fv4.qe.rhcloud.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}

TASK [cockpit-ui : Copy the admin client config(s)] ****************************
Tuesday 19 June 2018  04:28:19 -0400 (0:00:00.033)       0:15:04.955 ********** 
skipping: [qe-jialiu310-master-etcd-1.0619-fv4.qe.rhcloud.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}

TASK [cockpit-ui : Deploy registry-console] ************************************
Tuesday 19 June 2018  04:28:19 -0400 (0:00:00.031)       0:15:04.987 ********** 
skipping: [qe-jialiu310-master-etcd-1.0619-fv4.qe.rhcloud.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}

TASK [cockpit-ui : Delete temp directory] **************************************
Tuesday 19 June 2018  04:28:19 -0400 (0:00:00.032)       0:15:05.019 ********** 
skipping: [qe-jialiu310-master-etcd-1.0619-fv4.qe.rhcloud.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}


[root@qe-jialiu310-master-etcd-1 ~]# oc get dc
NAME              REVISION   DESIRED   CURRENT   TRIGGERED BY
docker-registry   1          1         1         config
router            1          1         1         config

Comment 22 Anping Li 2018-06-29 09:08:24 UTC
(In reply to Clayton Coleman from comment #16)
> In 3.10 registry console will go to the master nodes in all scenarios.  For
> making it optional, please submit a PR and I'll help review it and get it in.

Why the regsity console must be on master nodes?    Shouldn't it go by default to the nodes where registries are being scheduled?

Comment 24 errata-xmlrpc 2018-07-30 19:08:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.