Bug 1425096 - Overcloud upgrade fails with: Error: Evaluation Error: Error while evaluating a Resource Statement, Class[Pacemaker::Stonith]: has no parameter named 'tries' at /etc/puppet/modules/tripleo/manifests/profile/base/pacemaker.pp:105:5 on node overcloud-contro
Summary: Overcloud upgrade fails with: Error: Evaluation Error: Error while evaluating...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-pacemaker
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Michele Baldessari
QA Contact: Tomas Jamrisko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-20 14:47 UTC by Marius Cornea
Modified: 2017-05-17 20:01 UTC (History)
15 users (show)

Fixed In Version: puppet-pacemaker-0.5.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:01:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
RDO 5568 None None None 2017-03-02 14:22:59 UTC

Description Marius Cornea 2017-02-20 14:47:01 UTC
Description of problem:
Overcloud upgrade fails with: Error: Evaluation Error: Error while evaluating a Resource Statement, Class[Pacemaker::Stonith]: has no parameter named 'tries' at /etc/puppet/modules/tripleo/manifests/profile/base/pacemaker.pp:105:5 on node overcloud-contro

Version-Release number of selected component (if applicable):
puppet-pacemaker-0.4.0-1.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Upgrade overcloud from OSP10 to OSP11

Actual results:
Upgrade fails.

Expected results:
Upgrade succeeds.

Additional info:
This is fixed by https://trunk.rdoproject.org/centos7/current/puppet-pacemaker-0.5.0-0.20170214145103.b135ebb.el7.centos.noarch.rpm

Comment 2 Mike Burns 2017-02-23 17:01:41 UTC
> Additional info:
> This is fixed by
> https://trunk.rdoproject.org/centos7/current/puppet-pacemaker-0.5.0-0.
> 20170214145103.b135ebb.el7.centos.noarch.rpm

This build is master not ocata.  puppet-pacemaker appears branchless, so we need to get the pin updated in RDO in order to get this downstream.

Comment 3 Michele Baldessari 2017-02-27 11:42:03 UTC
(In reply to Mike Burns from comment #2)
> > Additional info:
> > This is fixed by
> > https://trunk.rdoproject.org/centos7/current/puppet-pacemaker-0.5.0-0.
> > 20170214145103.b135ebb.el7.centos.noarch.rpm
> 
> This build is master not ocata.  puppet-pacemaker appears branchless, so we
> need to get the pin updated in RDO in order to get this downstream.

Hi Mike, I'll be happy to help here although I am not entirely sure what "updating the pin in RDO" entails. Do I just need to ping Haikel/Alan and they will know?

Comment 4 Mike Burns 2017-03-02 13:12:40 UTC
(In reply to Michele Baldessari from comment #3)
> (In reply to Mike Burns from comment #2)
> > > Additional info:
> > > This is fixed by
> > > https://trunk.rdoproject.org/centos7/current/puppet-pacemaker-0.5.0-0.
> > > 20170214145103.b135ebb.el7.centos.noarch.rpm
> > 
> > This build is master not ocata.  puppet-pacemaker appears branchless, so we
> > need to get the pin updated in RDO in order to get this downstream.
> 
> Hi Mike, I'll be happy to help here although I am not entirely sure what
> "updating the pin in RDO" entails. Do I just need to ping Haikel/Alan and
> they will know?

Yes, Alan/Haikel can help you out with this.

Comment 5 Alan Pevec 2017-03-02 14:15:04 UTC
Background on puppet pins is in commit msg from amoralej in https://review.rdoproject.org/r/4673
tl;dr we pin at RC  time last-known-good puppet modules which do not do releases

To update it, look for - project: puppet-pacemaker in rdoinfo and update source-branch under ocata
as done by Haikel for this issue in https://review.rdoproject.org/r/5568

Comment 6 Michele Baldessari 2017-03-02 21:15:51 UTC
Mike, I think we should be good here now?
https://trunk.rdoproject.org/centos7-ocata/current/puppet-pacemaker-0.5.0-0.20170302152311.fe4d448.el7.centos.noarch.rpm

Comment 7 Marios Andreou 2017-03-08 14:20:58 UTC
bump... still hitting this on latest OSP11 puddle (the workaround that works for me today is to install puppet-pacemaker from rdo repos)


[root@overcloud-controller-0 ~]# rpm -qa | grep puppet-pacemaker
puppet-pacemaker-0.4.0-1.el7ost.noarch


        2017-03-08 14:14:50Z [overcloud-AllNodesDeploySteps-5ynyyqxffekt.AllNodesPostUpgradeSteps.ControllerDeployment_Step1]: CREATE_FAILED  Error: resources.ControllerDeployment_Step1.resources[1]: Deployment to server failed: deploy_status_code: Deployment exited with non-zero status code: 1
        2017-03-08 14:14:51Z [overcloud-AllNodesDeploySteps-5ynyyqxffekt.AllNodesPostUpgradeSteps]: CREATE_FAILED  Resource CREATE failed: Error: resources.ControllerDeployment_Step1.resources[1]: Deployment to server failed: deploy_status_code: Deployment exited with non-zero status code: 1
        2017-03-08 14:14:51Z [overcloud-AllNodesDeploySteps-5ynyyqxffekt.AllNodesPostUpgradeSteps]: CREATE_FAILED  Error: resources.AllNodesPostUpgradeSteps.resources.ControllerDeployment_Step1.resources[1]: Deployment to server failed: deploy_status_code: Deployment exited with non-zero status code: 1
        2017-03-08 14:14:51Z [overcloud-AllNodesDeploySteps-5ynyyqxffekt]: UPDATE_FAILED  Error: resources.AllNodesPostUpgradeSteps.resources.ControllerDeployment_Step1.resources[1]: Deployment to server failed: deploy_status_code: Deployment exited with non-zero status code: 1
        2017-03-08 14:14:52Z [AllNodesDeploySteps]: UPDATE_FAILED  resources.AllNodesDeploySteps: Error: resources.AllNodesPostUpgradeSteps.resources.ControllerDeployment_Step1.resources[1]: Deployment to server failed: deploy_status_code: Deployment exited with non-zero status code: 1
        2017-03-08 14:14:52Z [overcloud]: UPDATE_FAILED  resources.AllNodesDeploySteps: Error: resources.AllNodesPostUpgradeSteps.resources.ControllerDeployment_Step1.resources[1]: Deployment to server failed: deploy_status_code: Deployment exited with non-zero status code: 1

         Stack overcloud UPDATE_FAILED 

        Heat Stack update failed.

        Mar 08 14:14:47 overcloud-controller-0.localdomain os-collect-config[262395]: t::Integer. There is further documentation for validate_legacy function in the README. at [\"/var/lib/heat-config/heat-config-puppet/2faf3c95-eb15-42ef-a747-a25b016b8e31.pp\", 72]:[\"/etc/puppet/modules/tripleo/manifests/profile/pacemaker/rabbitmq.pp\", 62]\n   (at /etc/puppet/modules/stdlib/lib/puppet/functions/deprecation.rb:25:in `deprecation')\u001b[0m\n\u001b[1;33mWarning: Unknown variable: 'haproxy_stats_bind_certificate'. at /etc/puppet/modules/tripleo/manifests/haproxy.pp:769:6\u001b[0m\n\u001b[1;33mWarning: This method is deprecated, please use match expressions with Stdlib::Compat::String instead. They are described at https://docs.puppet.com/puppet/latest/reference/lang_data_type.html#match-expressions. at [\"/var/lib/heat-config/heat-config-puppet/2faf3c95-eb15-42ef-a747-a25b016b8e31.pp\", 77]:[\"/etc/puppet/modules/tripleo/manifests/profile/base/memcached.pp\", 30]\n   (at /etc/puppet/modules/stdlib/lib/puppet/functions/deprecation.rb:25:in `deprecation')\u001b[0m\n\u001b[1;31mError: Evaluation Error: Error while evaluating a Resource Statement, Class[Pacemaker::Stonith]: has no parameter named 'tries' at /etc/puppet/modules/tripleo/manifests/profile/base/pacemaker.pp:105:5 on node overcloud-controller-0.localdomain\u001b[0m\n", "deploy_status_code": 1}

Comment 8 Michele Baldessari 2017-03-13 10:05:52 UTC
Mike, I think we should "just" pull this in a new puddle, right?

Comment 13 errata-xmlrpc 2017-05-17 20:01:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.