Bug 1425116 - OSP10 -> OSP11 upgrade fails during aodh-dbsync
Summary: OSP10 -> OSP11 upgrade fails during aodh-dbsync
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-aodh
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Pradeep Kilambi
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-20 15:28 UTC by Marius Cornea
Modified: 2017-05-17 20:01 UTC (History)
10 users (show)

Fixed In Version: openstack-aodh-4.0.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:01:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 431055 None None None 2017-02-20 15:28:58 UTC
OpenStack gerrit 437417 None None None 2017-02-23 16:19:02 UTC

Description Marius Cornea 2017-02-20 15:28:58 UTC
Description of problem:
OSP10 -> OSP11 overcloud upgrade fails during aodh-dbsync:
ProgrammingError: (pymysql.err.ProgrammingError) (1146, u"Table 'aodh.alarm_change' doesn't exist") [SQL: u'ALTER TABLE alarm_change ADD COLUMN timestamp_ts DATETIME(6)']


Version-Release number of selected component (if applicable):
openstack-aodh-evaluator-4.0.1-0.20170210160347.e062a0a.el7ost.noarch
openstack-aodh-common-4.0.1-0.20170210160347.e062a0a.el7ost.noarch
openstack-aodh-notifier-4.0.1-0.20170210160347.e062a0a.el7ost.noarch
openstack-aodh-listener-4.0.1-0.20170210160347.e062a0a.el7ost.noarch
openstack-aodh-api-4.0.1-0.20170210160347.e062a0a.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Upgrade OSP10 overcloud to OSP11 overcloud

Actual results:
Overcloud upgrade fails:

    Error: /Stage[main]/Aodh::Db::Sync/Exec[aodh-db-sync]: Failed to call refresh: aodh-dbsync --config-file /etc/aodh/aodh.conf returned 1 instead of one of [0]
    Error: /Stage[main]/Aodh::Db::Sync/Exec[aodh-db-sync]: aodh-dbsync --config-file /etc/aodh/aodh.conf returned 1 instead of one of [0]
    Error: /Stage[main]/Gnocchi::Db::Sync/Exec[gnocchi-db-sync]: Failed to call refresh: gnocchi-upgrade --config-file /etc/gnocchi/gnocchi.conf --skip-storage returned 1 instead of one of [0]
    Error: /Stage[main]/Gnocchi::Db::Sync/Exec[gnocchi-db-sync]: gnocchi-upgrade --config-file /etc/gnocchi/gnocchi.conf --skip-storage returned 1 instead of one of [0]


Expected results:
aodh-dbsync --config-file /etc/aodh/aodh.conf gets run successfully

Additional info:
This is already fixed in upstream:
https://review.openstack.org/#/c/431055/

Comment 2 Mike Burns 2017-02-23 14:09:06 UTC
> Additional info:
> This is already fixed in upstream:
> https://review.openstack.org/#/c/431055/

It's fixed in upstream *master*.  It is not available in the stable/ocata branch.  Please work with the Telemetry team to get it backported to stable ocata.

Comment 5 errata-xmlrpc 2017-05-17 20:01:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.