Bug 142516 - /sbin/pidof (and also pstree) hang the boot process on kernel 2.6.6 (fc2 binary release)
/sbin/pidof (and also pstree) hang the boot process on kernel 2.6.6 (fc2 bina...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-09 23:13 EST by Stig Hackvan
Modified: 2015-01-04 17:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-02 19:36:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stig Hackvan 2004-12-09 23:13:10 EST
Description of problem:

on older kernels 2.6.6 [see below], /sbin/pidof hangs the boot process
(first in /sbin/start_udev [see bug #141774] but also in
/etc/rc.d/rc.sysinit)

Version-Release number of selected component (if applicable):

FC3 system with all updates applied, running the
last-known-working-kernel (see various USB-STORAGE bugs filed under
kernel) from the FC2 updates 

## ...ar-cache-apt-FC2+/archives >> wh pidof
pidof is /sbin/pidof
--
lrwxrwxrwx  1 root root 8 Nov 21 17:43 /sbin/pidof -> killall5
--
Name        : SysVinit                     Relocations: (not relocatable)
Version     : 2.85                              Vendor: Red Hat, Inc.
Release     : 34                            Build Date: Thu 07 Oct
2004 05:22:07 AM PDT
Install Date: Sun 21 Nov 2004 05:43:12 PM PST      Build Host:
tweety.build.redhat.com
Group       : System Environment/Base       Source RPM:
SysVinit-2.85-34.src.rpmSize        : 166636                         
 License: GPL
Signature   : DSA/SHA1, Wed 20 Oct 2004 09:02:40 AM PDT, Key ID
b44269d04f2a6fd2Packager    : Red Hat, Inc.
<http://bugzilla.redhat.com/bugzilla>
Summary     : Programs which control basic system processes.
Description :
The SysVinit package contains a group of processes that control
the very basic functions of your system. SysVinit includes the init
program, the first program started by the Linux kernel when the
system boots. Init then controls the startup, running, and shutdown
of all other programs.

## ...ar-cache-apt-FC2+/archives >> rpm -qip
kernel-2.6.6-1.435.2.3.i686.rpm
Name        : kernel                       Relocations: (not relocatable)
Version     : 2.6.6                             Vendor: Red Hat, Inc.
Release     : 1.435.2.3                     Build Date: Thu 01 Jul
2004 05:49:45 AM PDT
Install Date: (not installed)               Build Host:
tweety.build.redhat.com
Group       : System Environment/Kernel     Source RPM:
kernel-2.6.6-1.435.2.3.src.rpm
Size        : 35220692                         License: GPLv2
Signature   : DSA/SHA1, Thu 01 Jul 2004 02:07:31 PM PDT, Key ID
b44269d04f2a6fd2Packager    : Red Hat, Inc.
<http://bugzilla.redhat.com/bugzilla>
Summary     : The Linux kernel (the core of the Linux operating system).
Description :
The kernel package contains the Linux kernel (vmlinuz), the core of
the Red Hat Linux operating system. The kernel handles the basic
functions of the operating system: memory allocation, process
allocation, device input and output, etc.

How reproducible:

on an up2date FC3 system, install kernel-2.6.6-1.435.2.3.i686.rpm and
boot from it.  

starting udev, the system will hang.  if you boot single user and type
^C when udev starts, you get a shell prompt.  pidof will hang, but so
will pstree.
Comment 1 Bill Nottingham 2004-12-10 16:45:49 EST
If you strace it, where does it hang?
Comment 2 Stig Hackvan 2004-12-13 14:25:43 EST
'strace ps' hangs while reading '/proc/6/stat'...  it opens with fd of
7 and the next line is "read(7," with nothing to follow.

Comment 3 Bill Nottingham 2004-12-13 20:15:43 EST
Assigning to kernel... that should definitely not hang.
Comment 4 Dave Jones 2004-12-23 19:01:59 EST
seems fine to me in 2.6.9-1.715_FC3
can you still reproduce this ?
Comment 5 Stig Hackvan 2004-12-24 02:15:44 EST
the bug was originally posted because of fc3 failing to run on kernels shipped
with fc2.  i have had huge problems with the fc3 kernels, so the point of
posting a bug was to suggest that libraries and system utilities honor the
quirks of relatively recent kernels (those from fc2)...  i don't know if there
are enough resources to do that...and it may be that my problems with the fc3
kernels are addressed in some of the fc4 dev kernels...

i don't think of this as a kernel "bug" so much as a kernel change that prevents
tools built against 2.6.9 kernel headers from working with 2.6.6 kernels.  if
there were a fix, it would only be implementable in sysvinit and
pstools...because i wanted to be able to downgrade the kernel to the
last-known-to-work kernel from fc2...instead of reverting my whole system.

--stig
Comment 6 Dave Jones 2005-07-15 16:43:11 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 7 Stig Hackvan 2005-08-02 19:36:02 EDT
as originally reported, this bug was for versions of the FC2 kernel (which had
working drivers for my hardware that the early FC3 kernels lacked) used with FC3.  

I'm using the current fc3 kernels and they work for me.  i no longer have the
boot problems cited in this report.

Note You need to log in before you can comment on or make changes to this bug.