Bug 142520 - GTK1 GTK2 first day of month
GTK1 GTK2 first day of month
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: jpilot (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-10 04:02 EST by Josef Bauer
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-05 04:15:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Bauer 2004-12-10 04:02:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
their are a couple of small bugs in jpilot 0.99.7 if it is compiled
with GTK2.
e.g. first day of the week monday does not work, switch to the next or
previous month often skips a month, jump to the current day causes a
lot of jumping between first day in month an current day.
the author sugges to use the current CVS version or compile it with GTK1.


Version-Release number of selected component (if applicable):
jpilot-0.99.7-2

How reproducible:
Always

Steps to Reproduce:
e.g. settings
first day of month is to monday

    

Actual Results:  first day of month is sunday

Expected Results:  first day of month to be monday

Additional info:

e.g. using http://jpilot.org/jpilot-0.99.7-1.i386.rpm which is
compiled with GTK1 fixes all the bugs.
Comment 1 Ivana Varekova 2005-01-03 11:25:38 EST
Thank you for your notice. 
Jpilot developers fixed the problem with first day of week. I will
update rpm after fixed version will be released. 
The second problem with skipping a month probably is not a bug becouse
of if you press the mouse button for longer time month will keep
changing (this is different from Jpilot compiled with GTK) until you
release the mouse button. This is the only way I can reproduce this
problem.
The last problem is jumping between first day of the month and the
current day. I don't know where the problem is. Can you write steps to
reproduce. 
Ivana Varekova
Comment 2 Josef Bauer 2005-01-03 15:29:58 EST
Re the second problem: but it is not possible to skip a single month.
Try:
1. "Datebook/Jump to Today" Symbol
2. Left Symbol (for next month) next the current month
With my version you skip a whole month and jump to March.
Again Left Symbol and JPilot jumps to may.
Re last problem: If i click on the "Datebook/Jump to Today" Symbol, in
the area where time and appointments are listed, first the
appointments of the first day of the month are shown twice bevor the
appointments of the current day appear. Maybe this flickering is only
visible if there are a few appointments (on my computer 1 ghz, 40
appointments on the first day of month and in current day, it takes
about 1-2 seconds).
Comment 3 Ivana Varekova 2005-01-04 08:45:43 EST
Thank you for your notice.
Re 2: I try to reproduce the problem, but I can't reproduce it, my
JPilot (JPilot version 0.99.7-2, GTK2 version 2.4.14, fc3) works well.
There is not this problem. Probably, you may try to test some other
program which use GTK2 and it's calendar. What version of GTK2 do  you
use?
Re 3: I try to reproduce it but also I don not find this problem, my
JPilot was all right. I use more than 40 appointments and my Jpilot
works well. It show the right appointments and it works quite fast. I
don't know where the problem may be. Perhaps you have a different
version of GTK2.
Ivana Varekova
Comment 4 Josef Bauer 2005-01-04 09:31:57 EST
I use FC3 with:
jpilot-0.99.7-2
gtk2-2.4.14-1.fc3
Comment 5 Ivana Varekova 2005-01-05 04:15:39 EST
I use the same versions and releases of packages GTK2 and JPilot and
my JPilot works correctly. I don't find these two errors. 

After the new version (which will correct the first error) will be
released I will update JPilot.
I don't find other errors. In this cases JPilot works for me. 
Ivana Varekova
Comment 6 Josef Bauer 2005-01-09 05:35:44 EST
Maybe it has something to with my LANG setting.
I do not use UTF.
/etc/sysconfig/i18n:
LANG="en_US"
SUPPORTED="en_US.UTF-8:en_US:en:de_AT.UTF-8:de_AT:de"
SYSFONT="latarcyrheb-sun16"
and in JPilot I use:
"Latin1 / No conversion"
Comment 7 Ivana Varekova 2005-01-10 09:04:16 EST
Thank you for your notices. 
I look at your bugs again with your language setting. 
The second bug (problem with skipping a month) was OK. 
But I notice your last bug. I didn't notice it, becouse it was quite
fast.  
I fixed this bug. It's status is now "modified". This problem will be
fixed in new version jpilot-0.99.7-4.  
If you find some other information which can help with reproducation
of the second problem send it.
Ivana Varekova

Note You need to log in before you can comment on or make changes to this bug.