Bug 142525 - Selinux extensions create lots of dump errors
Selinux extensions create lots of dump errors
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dump (Show other bugs)
3
All Linux
medium Severity low
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-10 05:20 EST by Simon Andrews
Modified: 2013-07-02 19:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-16 08:30:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Path to suppress the warnings (922 bytes, patch)
2004-12-14 08:35 EST, Jindrich Novy
no flags Details | Diff

  None (edit)
Description Simon Andrews 2004-12-10 05:20:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
When trying to run dump on an Ext3 filesystem which supports the
selinux ACL extensions I get a ton of errors from dump saying:

DUMP: ACLs in inode #12 won't be dumped

..and this repeats for every inode.

Having discussed this on the fedora mailing list it isn't much of a
problem that the ACLs aren't stored since they can be retrieved with
restorecon, but the volume of errors currently makes dump unusable.

Version-Release number of selected component (if applicable):
dump-0.4b37-1

How reproducible:
Always

Steps to Reproduce:
1.Run dump on an selinux enabled Ext3 filesystem
2.
3.
    

Actual Results:  Lots and lots of errors

Expected Results:  Preferably that dump should retain and restore the
extra ACL information, but more realistically in the short term a
single warning in the output that ACLs are not supported rather than a
separate warning for each inode.

Additional info:

I'm putting this down as a high priority since it's actually stopping
us (and presumably others) from running our normal backup routines.
Comment 1 Stelian Pop 2004-12-10 05:28:15 EST
Those are NOT errors but warning messages, which are completly
harmless. If the high amount of warnings bothers you, feel free to
pipe the dump stderr output through 'grep -v "ACLs in inode"' or even
comment out the printf in the sources.

That being said, I am working right now on implementing EA support in
dump (already done) and in restore (much more tricky). I plan on
having an alpha version really soon now, but the changes to restore
are rather intrusive so it will have to go through a beta test period
before including it into the mainline dump.

If you're interested in beta testing, just say so.

Stelian.
Comment 2 Stelian Pop 2004-12-14 08:05:43 EST
BTW, the patch implementing EA support is available now from
http://dump.sourceforge.net

Comment 3 Jindrich Novy 2004-12-14 08:35:00 EST
Created attachment 108514 [details]
Path to suppress the warnings

Simon, please apply this patch if you want to get rid of these warnings.
Comment 4 Jindrich Novy 2004-12-14 08:36:56 EST
Stellian, thanks for the quick response. Moving severity to low as it
doesn't affect functionality of dump.
Comment 5 Simon Andrews 2004-12-14 11:06:21 EST
Just thought I'd add a comment to say that having used the workaround
suggested I've got our backups going again and all seems to be well. 
I'll look at the new CVS version next week and report back with any
problems.

Many thanks for a quick response to this issue.

Simon.
Comment 6 Stelian Pop 2004-12-15 06:46:13 EST
In fact you need both the CVS version and the dump-ea patch from:
http://dump.sourceforge.net/dump-ea.patch.bz2

Stelian.
Comment 7 Jindrich Novy 2004-12-16 08:30:32 EST
Resolving NOTABUG as the warning messages are not a bug but a feature.

Note You need to log in before you can comment on or make changes to this bug.