Bug 1425306 - typo error in virt-tail man page
Summary: typo error in virt-tail man page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1359086
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-21 07:24 UTC by Xianghua Chen
Modified: 2017-08-01 22:11 UTC (History)
3 users (show)

Fixed In Version: libguestfs-1.36.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 22:11:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2023 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2017-08-01 19:32:01 UTC

Description Xianghua Chen 2017-02-21 07:24:31 UTC
Description of problem:
Typo error in virt-tail man page:

EXAMPLE
       Follow /var/log/messages inside a virtual machine called "mydomain":
        virt-tail -d mydomain /etc/fstab

The “/var/log/messages” should be consistent with "/etc/fstab".


Version-Release number of selected component (if applicable):
libguestfs-1.34.3-2.el7.x86_64
>From repo:  https://people.redhat.com/~rjones/libguestfs-RHEL-7.4-preview/

How reproducible:
100%

Steps:


Actual results:


Expected results:


Additional info:

Comment 1 Richard W.M. Jones 2017-02-21 08:30:57 UTC
I'm somewhat confused what the problem is here.  Can you describe
exactly what is the issue?

In any case, the original POD markup is correct:

=head1 EXAMPLE                                                                  
                                                                                
Follow F</var/log/messages> inside a virtual machine called C<mydomain>:        
                                                                                
 virt-tail -d mydomain /etc/fstab

Comment 2 Xianghua Chen 2017-02-21 09:20:35 UTC
(In reply to Richard W.M. Jones from comment #1)
> I'm somewhat confused what the problem is here.  Can you describe
> exactly what is the issue?
> 
> In any case, the original POD markup is correct:
> 
> =head1 EXAMPLE                                                              
> 
>                                                                             
> 
> Follow F</var/log/messages> inside a virtual machine called C<mydomain>:    
> 
>                                                                             
> 
>  virt-tail -d mydomain /etc/fstab

Shouldn't the “/var/log/messages” be consistent with "/etc/fstab"?
The example is saying that follow the file : /var/log/mesages, but the command line you use /etc/fstab , I think that would confuse the user.

Comment 3 Richard W.M. Jones 2017-02-21 11:25:35 UTC
/etc/fstab is in a verbatim section.

It all looks good in the HTML version:

http://libguestfs.org/virt-tail.1.html#example

I don't really think this is a bug.  It's just that the
text-based man page output doesn't have enough formatting
available to show verbatim sections in a different font.

Comment 4 Pino Toscano 2017-02-21 11:40:15 UTC
Rich: the issue is that the man page says "see how you can monitor /var/log/messages", but the example for it (which follows) mentions /etc/fstab.

Comment 5 Richard W.M. Jones 2017-02-21 12:07:44 UTC
Oh I see ...  yes, this is a bug, patch posted:

https://github.com/libguestfs/libguestfs/commit/2643c4d5f425b216d0d3fadee8f0f4ed69cfafba

Comment 7 Xianghua Chen 2017-03-28 06:18:27 UTC
Verify with packages:
libguestfs-1.36.2-3.el7.x86_64

Steps:
1.
# man virt-tail
... ...
EXAMPLE
       Follow /var/log/messages inside a virtual machine called "mydomain":

        virt-tail -d mydomain /var/log/messages



So verified.

Comment 8 errata-xmlrpc 2017-08-01 22:11:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2023


Note You need to log in before you can comment on or make changes to this bug.