Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1425317 - pcs auth will fail with false error message if pcsd-cli.rb outputs to stderr
Summary: pcs auth will fail with false error message if pcsd-cli.rb outputs to stderr
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcs
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Tomas Jelinek
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-21 07:57 UTC by Xu Yin
Modified: 2020-03-09 12:35 UTC (History)
10 users (show)

Fixed In Version: pcs-0.9.156-1.el7
Doc Type: Bug Fix
Doc Text:
Cause: The user runs the "pcs cluster auth" command. Consequence: Sometimes the command may exit with an error even though it actually succeeded. Fix: Properly parse the output of a script which does the actual authentication. Result: The "pcs cluster auth" command works.
Clone Of:
Environment:
Last Closed: 2017-08-01 18:26:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2273581 None None None 2019-08-20 07:34:11 UTC
Red Hat Product Errata RHBA-2017:1958 normal SHIPPED_LIVE pcs bug fix and enhancement update 2017-08-01 18:09:47 UTC

Description Xu Yin 2017-02-21 07:57:06 UTC
Description of problem:
Please backport https://github.com/ClusterLabs/pcs/issues/124 (patch https://github.com/ClusterLabs/pcs/commit/03f17f86f68675b8d20da664e66617ce3e614de4?diff=split)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Add a directory (With world writable permisson, like 666) to PATH.
2. # pcs cluster auth pcmk1 pcmk2 --debug
3.

Actual results:

Error: Unable to communicate with pcsd


Expected results:

pcmk1: Already authorized
pcmk2: Already authorized


Additional info:
In our environment (RHEL7.3), patching https://github.com/ClusterLabs/pcs/commit/03f17f86f68675b8d20da664e66617ce3e614de4?diff=split can solve the issue.

Comment 1 Tomas Jelinek 2017-02-21 09:21:01 UTC
Patch in upstream:
https://github.com/ClusterLabs/pcs/commit/03f17f86f68675b8d20da664e66617ce3e614de4

Reproducer:
[root@rh73-node1:~]# chmod 777 /usr
[root@rh73-node1:~]# pcs cluster auth rh73-node1 rh73-node2 rh73-node3 -u hacluster -p password

Before fix:
[root@rh73-node1:~]# rpm -q pcs
pcs-0.9.152-10.el7_3.1.x86_64
[root@rh73-node1:~]# pcs cluster auth rh73-node1 rh73-node2 rh73-node3 -u hacluster -p password
Error: Unable to communicate with pcsd

After Fix:
[root@rh73-node1:~]# rpm -q pcs
pcs-0.9.156-1.el7.x86_64
[root@rh73-node1:~]# pcs cluster auth rh73-node1 rh73-node2 rh73-node3 -u hacluster -p password
rh73-node1: Authorized
rh73-node3: Authorized
rh73-node2: Authorized

Comment 6 errata-xmlrpc 2017-08-01 18:26:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1958


Note You need to log in before you can comment on or make changes to this bug.