Bug 142534 - gpm locks the keyboard if no mouse is present
Summary: gpm locks the keyboard if no mouse is present
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gpm (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
low
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-10 14:40 UTC by Stefan Kutzke
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 16:22:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stefan Kutzke 2004-12-10 14:40:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040803 Firefox/0.8

Description of problem:
The keyboard doesn't work after booting a machine into  runlevel 3
with gpm service configured an running and no mouse is connected.



Version-Release number of selected component (if applicable):
gpm-1.19.3-27.2

How reproducible:
Always

Steps to Reproduce:
1. Configuring mouse wtih redhat-config-mouse or by hand.
2. Disconnect the mouse.
3. Reboot the machine.
    

Actual Results:  The keyboard doesn't work.

Expected Results:  The keyboard should work regardless if a mouse is
connected or not.

Additional info:

It's not really a problem. I do a chkconfig gpm off and throw the
mouse away :-)

Comment 1 Eido Inoue 2004-12-10 16:22:39 UTC
Couldn't reproduce using your steps; may be hw specific. Some
systems-- especially those using PS/2 mice-- are less forgiving about
unplugging/plugging in mice without power cycling (rebooting may not
be enough).


Comment 2 Stefan Kutzke 2004-12-13 16:16:38 UTC
You are right, it's hw specific. Power cycling the server machine
solves the problem.


Note You need to log in before you can comment on or make changes to this bug.