Bug 1425357 - AVC: nmbd calls epoll_ctl
Summary: AVC: nmbd calls epoll_ctl
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
: 1458777 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-21 09:36 UTC by Robin Hack
Modified: 2017-08-01 15:22 UTC (History)
7 users (show)

Fixed In Version: selinux-policy-3.13.1-130.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 15:22:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1861 0 normal SHIPPED_LIVE selinux-policy bug fix update 2017-08-01 17:50:24 UTC

Description Robin Hack 2017-02-21 09:36:05 UTC
Description of problem:
Hello. After rebase to samba 4.6 looks like nmbd needs epoll_ctl syscall allowed by selinux.


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. use nmbd
2.
3.

Actual results:
[ ERROR ] AVC check: FAIL
----
type=SYSCALL msg=audit(02/21/17 04:28:24.374:379) : arch=x86_64 syscall=epoll_ctl success=yes exit=0 a0=0x4 a1=EPOLL_CTL_DEL a2=0x15 a3=0x7ffe13f9ce80 items=0 ppid=1 pid=2787 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=nmbd exe=/usr/sbin/nmbd subj=system_u:system_r:nmbd_t:s0 key=(null)
type=AVC msg=audit(02/21/17 04:28:24.374:379) : avc:  denied  { block_suspend } for  pid=2787 comm=nmbd capability=block_suspend  scontext=system_u:system_r:nmbd_t:s0 tcontext=system_u:system_r:nmbd_t:s0 tclass=capability2
----
type=SYSCALL msg=audit(02/21/17 04:28:24.374:380) : arch=x86_64 syscall=epoll_ctl success=yes exit=0 a0=0x4 a1=EPOLL_CTL_DEL a2=0x14 a3=0x7ffe13f9ce80 items=0 ppid=1 pid=2787 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=nmbd exe=/usr/sbin/nmbd subj=system_u:system_r:nmbd_t:s0 key=(null)
type=AVC msg=audit(02/21/17 04:28:24.374:380) : avc:  denied  { block_suspend } for  pid=2787 comm=nmbd capability=block_suspend  scontext=system_u:system_r:nmbd_t:s0 tcontext=system_u:system_r:nmbd_t:s0 tclass=capability2
----
type=SYSCALL msg=audit(02/21/17 04:28:24.374:381) : arch=x86_64 syscall=epoll_ctl success=yes exit=0 a0=0x4 a1=EPOLL_CTL_DEL a2=0x13 a3=0x7ffe13f9ce80 items=0 ppid=1 pid=2787 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=nmbd exe=/usr/sbin/nmbd subj=system_u:system_r:nmbd_t:s0 key=(null)
type=AVC msg=audit(02/21/17 04:28:24.374:381) : avc:  denied  { block_suspend } for  pid=2787 comm=nmbd capability=block_suspend  scontext=system_u:system_r:nmbd_t:s0 tcontext=system_u:system_r:nmbd_t:s0 tclass=capability2
----
type=SYSCALL msg=audit(02/21/17 04:28:24.374:382) : arch=x86_64 syscall=epoll_ctl success=yes exit=0 a0=0x4 a1=EPOLL_CTL_DEL a2=0x12 a3=0x7ffe13f9ce80 items=0 ppid=1 pid=2787 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=nmbd exe=/usr/sbin/nmbd subj=system_u:system_r:nmbd_t:s0 key=(null)
type=AVC msg=audit(02/21/17 04:28:24.374:382) : avc:  denied  { block_suspend } for  pid=2787 comm=nmbd capability=block_suspend  scontext=system_u:system_r:nmbd_t:s0 tcontext=system_u:system_r:nmbd_t:s0 tclass=capability2


Expected results:


Additional info:

Comment 2 Milos Malik 2017-02-21 09:50:33 UTC
Confirmed. I can reproduce the SELinux denials with following packages:

# rpm -qa selinux-policy\* samba\* | sort
samba-4.6.0-0.1.rc3.el7.x86_64
samba-client-libs-4.6.0-0.1.rc3.el7.x86_64
samba-common-4.6.0-0.1.rc3.el7.noarch
samba-common-libs-4.6.0-0.1.rc3.el7.x86_64
samba-common-tools-4.6.0-0.1.rc3.el7.x86_64
samba-libs-4.6.0-0.1.rc3.el7.x86_64
samba-winbind-4.6.0-0.1.rc3.el7.x86_64
samba-winbind-modules-4.6.0-0.1.rc3.el7.x86_64
selinux-policy-3.13.1-121.el7.noarch
selinux-policy-targeted-3.13.1-121.el7.noarch
#

Comment 7 Lukas Vrabec 2017-06-05 14:46:52 UTC
*** Bug 1458777 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2017-08-01 15:22:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1861


Note You need to log in before you can comment on or make changes to this bug.