Bug 1425437 - Update installer upgrade process to include resolving data integrity issues.
Summary: Update installer upgrade process to include resolving data integrity issues.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Sanket Jagtap
URL:
Whiteboard:
: 1382230 1390189 (view as bug list)
Depends On: 1375075 1446727
Blocks: 1365223 1446713
TreeView+ depends on / blocked
 
Reported: 2017-02-21 12:37 UTC by Brad Buckingham
Modified: 2020-08-13 08:53 UTC (History)
7 users (show)

Fixed In Version: katello-installer-base-3.0.0.81-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1446729 (view as bug list)
Environment:
Last Closed: 2017-06-20 17:22:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 18405 0 Normal Closed Update installer upgrade process to include resolving data integrity issues. 2020-03-21 15:46:16 UTC
Red Hat Product Errata RHBA-2017:1553 0 normal SHIPPED_LIVE Satellite 6.2.10 Async Bug Release 2017-06-20 21:19:07 UTC

Description Brad Buckingham 2017-02-21 12:37:21 UTC
There are a couple of issues that were worked on recently to provide/update rake tasks to allow users to resolve possible data integrity issues for repositories and hosts/consumers.  They included:

http://projects.theforeman.org/issues/17351 - e.g. added 'correct_repositories', 'correct_puppet_environments'...etc
http://projects.theforeman.org/issues/15721 - updated 'clean_backend_objects' 

This issue is to enhance the installer upgrade process to perform these rake tasks to resolve these issues, to avoid users having to debug and manually execute the tasks.

The intent/goal would be to add the following parameter to the installer:
   --clean-mismatches
   true/false: defaults to 'true'
   purpose: if 'true', execute the above tasks during the upgrade process.  if 'false', execute the tasks in a 'non-commit' mode to report to the user the changes that would have been made

Comment 1 Brad Buckingham 2017-02-21 12:37:25 UTC
Created from redmine issue http://projects.theforeman.org/issues/18405

Comment 3 Satellite Program 2017-02-22 17:01:14 UTC
Upstream bug assigned to bbuckingham

Comment 4 Satellite Program 2017-02-22 17:01:16 UTC
Upstream bug assigned to bbuckingham

Comment 5 Brad Buckingham 2017-03-06 18:31:04 UTC
Note: the solution added the following option/parameter to the installer:
  --disable-resolve-mismatches

This option will run the upgrade without making changes to address those mismatches.  It will still run those tasks and report the changes that it would have made, if not included.

Comment 7 Sanket Jagtap 2017-06-07 11:42:51 UTC
Build: Satellite 6.2.10 snap3 

Upgrade is performed from 6.1.z to 6.2.10 snap3

Verification Steps:
1. satellite-installer --upgrade

Log:
Upgrade Step: correct_repositories (this may take a while) ...
/opt/theforeman/tfm/root/usr/share/gems/gems/foreman_theme_satellite-0.1.43/app/models/concerns/satellite_packages.rb:4: warning: already initialized constant Katello::Ping::PACKAGES
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.135/app/models/katello/ping.rb:7: warning: previous definition of PACKAGES was here
Processing Repository 1/111: Red Hat Enterprise Linux 6 Server Kickstart x86_64 6.8 (1)
........
.......
Processing Repository 23/111: custom_repo_zoo (28)
Repository 28 Missing
Deleting 28
Processing Repository 24/110: Red Hat Enterprise Linux 6 Server Kickstart x86_64 6.8 (31)
.......
.......
Processing Repository 111/110: Red Hat Satellite Tools 6.1 for RHEL 7 Server RPMs x86_64 (183)

Upgrade Step: correct_puppet_environments (this may take a while) ...
/opt/theforeman/tfm/root/usr/share/gems/gems/foreman_theme_satellite-0.1.43/app/models/concerns/satellite_packages.rb:4: warning: already initialized constant Katello::Ping::PACKAGES
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.135/app/models/katello/ping.rb:7: warning: previous definition of PACKAGES was here
Processing Puppet Environment 1/29: Default_Organization-rhel7_cv-1 (1)
Processing Puppet Environment 29/29: Default_Organization-Dev-rhel7_cv (47)

Upgrade Step: clean_backend_objects (this may take a while) ...
/opt/theforeman/tfm/root/usr/share/gems/gems/foreman_theme_satellite-0.1.43/app/models/concerns/satellite_packages.rb:4: warning: already initialized constant Katello::Ping::PACKAGES
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.135/app/models/katello/ping.rb:7: warning: previous definition of PACKAGES was here
0 orphaned consumer id(s) found.

Comment 9 Partha Aji 2017-06-08 21:16:22 UTC
*** Bug 1382230 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2017-06-20 17:22:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1553

Comment 12 Justin Sherrill 2017-08-25 13:32:55 UTC
*** Bug 1390189 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.