Bug 1425438 - subscription-manager list --consumed shows the consumption of extra entitlement granted from the organization or environment.
Summary: subscription-manager list --consumed shows the consumption of extra entitlem...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: pre-dev-freeze
: ---
Assignee: Kevin Howell
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-21 12:37 UTC by Shwetha Kallesh
Modified: 2017-08-01 19:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:21:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1555 'None' closed 1425438: Hide content access certs from list cmd 2020-05-07 03:37:32 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Shwetha Kallesh 2017-02-21 12:37:26 UTC
Description of problem:
subscription-manager list --consumed  shows the consumption of extra entitlement granted from the organization or environment.

Version-Release number of selected component (if applicable):
[root@dell-per210-01 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.25-1
subscription management rules: 5.20
subscription-manager: 1.18.10-1.el6
python-rhsm: 1.18.6-1.el6


How reproducible:


Steps to Reproduce:
[root@dell-per210-01 ~]# curl -X PUT -k -u admin:admin   -d '{"contentAccessMode":"org_environment"}'  -H "Content-Type: application/json"  "https://shwetha-workstation.usersys.redhat.com:8443/candlepin/owners/snowwhite" | python -mjson.tool
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
127   469    0   469    0    39    278     23 --:--:--  0:00:01 --:--:--   975
{
    "autobindDisabled": null, 
    "contentAccessMode": "org_environment", 
    "contentAccessModeList": "org_environment", 
    "contentPrefix": null, 
    "created": "2017-02-17T10:35:09+0000", 
    "defaultServiceLevel": null, 
    "displayName": "Snow White", 
    "href": "/owners/snowwhite", 
    "id": "8ac6a39f5a4ba3af015a4ba3c8730003", 
    "key": "snowwhite", 
    "logLevel": null, 
    "parentOwner": null, 
    "updated": "2017-02-17T11:19:46+0000", 
    "upstreamConsumer": null
}
[root@dell-per210-01 ~]# subscription-manager register --force
The system with UUID 13c50319-3a39-4712-a81d-49432388196f has been unregistered
Registering to: shwetha-workstation.usersys.redhat.com:8443/candlepin
Username: admin
Password: 
Organization: snowwhite
The system has been registered with ID: bc8c8779-5427-4405-9a0e-8b24330a562c 


[root@dell-per210-01 ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name:   Content Access
Provides:             Content Access
SKU:                 content_access
Contract:            
Account:             
Serial:              3532449175399493811
Pool ID:             Not Available
Provides Management: No
Active:              True
Quantity Used:       1
Service Level:       
Service Type:        
Status Details:      Subscription is current
Subscription Type:   
Starts:              02/21/2017
Ends:                02/21/2018
System Type:         Physical

Actual results:
subscription-manager list --consumed shows the extra entitlement granted

Expected results:
subscription-manager list --consumed should not show the extra entitlement granted

Additional info:

Comment 4 Shwetha Kallesh 2017-04-07 10:00:47 UTC
Marking bug as verified!!

[root@dhcp70-154 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.1.0-1
subscription management rules: 5.23
subscription-manager: 1.19.4-1.el7
python-rhsm: 1.19.2-1.el7


[root@Shwetha-candlepin server]# curl -X PUT -k -u admin:admin   -d '{"contentAccessMode":"org_environment"}'  -H "Content-Type: application/json"  "https://Shwetha-candlepin.usersys.redhat.com:8443/candlepin/owners/snowwhite" | python -mjson.tool
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   437    0   398  100    39   1742    170 --:--:-- --:--:-- --:--:--  1745
{
    "autobindDisabled": null,
    "contentAccessMode": "org_environment",
    "contentAccessModeList": "org_environment",
    "contentPrefix": null,
    "created": "2017-04-07T09:51:58+0000",
    "defaultServiceLevel": null,
    "displayName": "Snow White",
    "href": "/owners/snowwhite",
    "id": "8ac6a3185b47d386015b47d3ddc60002",
    "key": "snowwhite",
    "logLevel": null,
    "parentOwner": null,
    "updated": "2017-04-07T09:55:26+0000",
    "upstreamConsumer": null
}


[root@dhcp70-154 ~]# subscription-manager register --force --serverurl Shwetha-candlepin.usersys.redhat.com:8443/candlepin
Registering to: Shwetha-candlepin.usersys.redhat.com:8443/candlepin
Username: admin
Password: 
Organization: snowwhite
The system has been registered with ID: 7a714b1d-7a84-46b6-b584-c64408a78f48 
1 local certificate has been deleted.
[root@dhcp70-154 ~]# subscription-manager list --consumed
No consumed subscription pools to list
[root@dhcp70-154 ~]# ls /etc/pki/entitlement/
8274670981311199976-key.pem  8274670981311199976.pem
[root@dhcp70-154 ~]# rct cat-cert /etc/pki/entitlement/8274670981311199976.pem 

+-------------------------------------------+
	Entitlement Certificate
+-------------------------------------------+

Certificate:
	Path: /etc/pki/entitlement/8274670981311199976.pem
	Version: 3.3
	Serial: 8274670981311199976
	Start Date: 2017-04-07 08:56:58+00:00
	End Date: 2018-04-07 08:56:58+00:00
	Pool ID: Not Available

Subject:
	CN: 7a714b1d-7a84-46b6-b584-c64408a78f48
	O: snowwhite

Issuer:
	C: US
	CN: Shwetha-candlepin.usersys.redhat.com
	L: Raleigh

Product:
	ID: content_access
	Name:  Content Access
	Version: 
	Arch: 
	Tags: 
	Brand Type: 
	Brand Name: 

Order:
	Name: Content Access
	Number: 
	SKU: content_access
	Contract: 
	Account: 
	Service Level: 
	Service Type: 
	Quantity: 
	Quantity Used: 1
	Socket Limit: 
	RAM Limit: 
	Core Limit: 
	Virt Only: False
	Stacking ID: 
	Warning Period: 0
	Provides Management: False

Content:
	Type: yum
	Name: awesomeos
	Label: awesomeos
	Vendor: Red Hat
	URL: /snowwhite/path/to/$basearch/$releasever/awesomeos
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: awesomeos-all
	Label: awesomeos-all
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos/all
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: 

Content:
	Type: containerImage
	Name: awesomeos-docker-images
	Label: awesomeos-docker-images
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos-docker-images
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: awesomeos-i386
	Label: awesomeos-i386
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos/i386
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: awesomeos-i386-only-content
	Label: awesomeos-i386-only-content
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos/all
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: i386

Content:
	Type: yum
	Name: awesomeos-i686
	Label: awesomeos-i686
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos/i686
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: awesomeos-ia64
	Label: awesomeos-ia64
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos/ia64
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: awesomeos-ia64-only-content
	Label: awesomeos-ia64-only-content
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos/all
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: ia64

Content:
	Type: ostree
	Name: awesomeos-ostree
	Label: awesomeos-ostree
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos-ostree
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: awesomeos-ppc
	Label: awesomeos-ppc
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos/ppc
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: awesomeos-ppc-only-content
	Label: awesomeos-ppc-only-content
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos/all
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: ppc

Content:
	Type: yum
	Name: awesomeos-ppc64
	Label: awesomeos-ppc64
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos/ppc64
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: awesomeos-ppc64-only-content
	Label: awesomeos-ppc64-only-content
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos/all
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: ppc64

Content:
	Type: yum
	Name: awesomeos-s390x
	Label: awesomeos-s390x
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos/s390x
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: awesomeos-s390x-only-content
	Label: awesomeos-s390x-only-content
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos/all
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: s390x

Content:
	Type: yum
	Name: awesomeos-x86
	Label: awesomeos-x86
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos/$releasever/x86
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: awesomeos-x86_64
	Label: awesomeos-x86_64
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos/x86_64
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: awesomeos-x86_64-i386-content
	Label: awesomeos-x86_64-i386-content
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos/all
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: x86_64, i386

Content:
	Type: yum
	Name: awesomeos-x86_64-only-content
	Label: awesomeos-x86_64-only-content
	Vendor: Red Hat
	URL: /snowwhite/path/to/awesomeos/all
	GPG: /path/to/awesomeos/gpg/
	Enabled: False
	Expires: 3600
	Required Tags: 
	Arches: x86_64

Content:
	Type: yum
	Name: content
	Label: content-label
	Vendor: test-vendor
	URL: /snowwhite/foo/path
	GPG: /foo/path/gpg/
	Enabled: False
	Expires: 0
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: content-emptygpg
	Label: content-label-empty-gpg
	Vendor: test-vendor
	URL: /snowwhite/foo/path
	GPG: 
	Enabled: False
	Expires: 0
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: content-nogpg
	Label: content-label-no-gpg
	Vendor: test-vendor
	URL: /snowwhite/foo/path
	GPG: 
	Enabled: False
	Expires: 0
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: never-enabled-content
	Label: never-enabled-content
	Vendor: test-vendor
	URL: /snowwhite/foo/path/never
	GPG: /foo/path/never/gpg
	Enabled: False
	Expires: 600
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: snowy-content
	Label: snowy-content-label
	Vendor: test-vendor
	URL: /snowwhite/snowy/foo/path
	GPG: /snowy/foo/path/gpg/
	Enabled: False
	Expires: 0
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: snowy-never-enabled-content
	Label: snowy-never-enabled-content
	Vendor: test-vendor
	URL: /snowwhite/snowy/foo/path/never
	GPG: /snowy/foo/path/never/gpg
	Enabled: False
	Expires: 600
	Required Tags: 
	Arches: 

Content:
	Type: yum
	Name: snowy-tagged-content
	Label: snowy-tagged-content
	Vendor: test-vendor
	URL: /snowwhite/snowy/foo/path/always
	GPG: /snowy/foo/path/always/gpg
	Enabled: False
	Expires: 
	Required Tags: TAG1, TAG2
	Arches: 

Content:
	Type: yum
	Name: tagged-content
	Label: tagged-content
	Vendor: test-vendor
	URL: /snowwhite/foo/path/always
	GPG: /foo/path/always/gpg
	Enabled: False
	Expires: 
	Required Tags: TAG1, TAG2
	Arches: 
[root@dhcp70-154 ~]#

Comment 5 errata-xmlrpc 2017-08-01 19:21:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.