This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 142546 - io_edgeport triggers kernel oops
io_edgeport triggers kernel oops
Status: CLOSED DUPLICATE of bug 128916
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-10 10:34 EST by Nick Maliszewskyj
Modified: 2015-01-04 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Maliszewskyj 2004-12-10 10:34:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When I plug in either and Edgeport/8 or Edgeport/4 USB - Serial
Converter, the kernel oopses, leaving the io_edgeport module
installed and the usb hotplug system hung.

This device worked splendidly under RedHat Linux 7.3-9.0 with kernel
2.4. What's the deal here?

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.681_FC3

How reproducible:
Always

Steps to Reproduce:
1. Boot system
2. Plug in edgeport

    

Actual Results:  The device is not recognized by the system (red
blinking light on the
box). USB probing now hangs irreversibly (can't do lsusb).

Expected Results:  The kernel module loads. USB probing still works.
Life goes on.

Additional info:

Dec 10 10:03:39 bt7 kernel: usb 5-1: new full speed USB device using
address 3
Dec 10 10:03:39 bt7 kernel: drivers/usb/serial/usb-serial.c: USB
Serial support registered for Generic
Dec 10 10:03:39 bt7 kernel: usbcore: registered new driver
usbserial_generic
Dec 10 10:03:39 bt7 kernel: usbcore: registered new driver usbserial
Dec 10 10:03:39 bt7 kernel: drivers/usb/serial/usb-serial.c: USB
Serial Driver core v2.0
Dec 10 10:03:39 bt7 kernel: drivers/usb/serial/usb-serial.c: USB
Serial support registered for Edgeport 2 port adapter
Dec 10 10:03:39 bt7 kernel: drivers/usb/serial/usb-serial.c: USB
Serial support registered for Edgeport 4 port adapter
Dec 10 10:03:39 bt7 kernel: drivers/usb/serial/usb-serial.c: USB
Serial support registered for Edgeport 8 port adapter
Dec 10 10:03:39 bt7 kernel: io_edgeport 5-1:1.0: Edgeport 8 port
adapter converter detected
Dec 10 10:03:39 bt7 kernel: usb 5-1: Inside Out Network Edgeport/8
detected
Dec 10 10:03:39 bt7 kernel: Unable to handle kernel paging request at
virtual address 00d04a82
Dec 10 10:03:39 bt7 kernel:  printing eip:
Dec 10 10:03:39 bt7 kernel: 00d04a82
Dec 10 10:03:39 bt7 kernel: *pde = 00000000
Dec 10 10:03:39 bt7 kernel: Oops: 0000 [#1]
Dec 10 10:03:39 bt7 kernel: Modules linked in: io_edgeport usbserial
i915 parport_pc lp parport autofs4 i2c_dev i2c_core sunrpc ipt_REJECT
ipt_state ip_conntrack iptable_filter ip_tables button battery ac md5
ipv6 joydev uhci_hcd ehci_hcd snd_intel8x0 snd_ac97_codec snd_pcm_oss
snd_mixer_oss snd_pcm snd_timer snd_page_alloc gameport
snd_mpu401_uart snd_rawmidi snd_seq_device snd soundcore e1000 floppy
dm_snapshot dm_zero dm_mirror ext3 jbd dm_mod ata_piix libata sd_mod
scsi_mod
Dec 10 10:03:39 bt7 kernel: CPU:    0
Dec 10 10:03:39 bt7 kernel: EIP:    0060:[<00d04a82>]    Not tainted VLI
Dec 10 10:03:39 bt7 kernel: EFLAGS: 00010213   (2.6.9-1.681_FC3)
Dec 10 10:03:39 bt7 kernel: EIP is at 0xd04a82
Dec 10 10:03:39 bt7 kernel: eax: 6ed8fe28   ebx: 7a634200   ecx:
ffffffff   edx: 00000000
Dec 10 10:03:39 bt7 kernel: esi: 6ed8fe28   edi: 7a63468c   ebp:
78779800   esp: 6ed8fe28
Dec 10 10:03:39 bt7 kernel: ds: 007b   es: 007b   ss: 0068
Dec 10 10:03:39 bt7 usb.agent[3439]: ... can't load module io_edgeport
Dec 10 10:03:39 bt7 kernel: Process modprobe (pid: 3475,
threadinfo=6ed8f000 task=6ede6d30)
Dec 10 10:03:39 bt7 usb.agent[3439]: missing kernel or user mode
driver io_edgeport
Dec 10 10:03:39 bt7 kernel: Stack: 33333356 36343736 00302d39 02120700
00000013 7a634200 7a63468c 02120552
Dec 10 10:03:40 bt7 kernel:        00000013 7a634200 82d04f46 82d06a4f
0233356e 78779934 7a634200 00000000
Dec 10 10:03:40 bt7 kernel:        809af840 39ce0c00 82d14d20 6ecfc380
00000001 82c45522 6ecfc548 00000000
Dec 10 10:03:40 bt7 kernel: Call Trace:
Dec 10 10:03:40 bt7 kernel:  [<02120700>] vprintk+0x1ab/0x2f5
Dec 10 10:03:40 bt7 kernel:  [<02120552>] printk+0xe/0x11
Dec 10 10:03:40 bt7 kernel:  [<82d04f46>] edge_startup+0xd3/0x243
[io_edgeport]
Dec 10 10:03:40 bt7 kernel:  [<82c45522>] usb_serial_probe+0x94e/0xae8
[usbserial]
Dec 10 10:03:40 bt7 kernel:  [<02181871>] d_instantiate+0x144/0x147
Dec 10 10:03:40 bt7 kernel:  [<021ab198>] sysfs_create+0x77/0x9c
Dec 10 10:03:40 bt7 kernel:  [<021abab5>] create_dir+0x83/0xa0
Dec 10 10:03:40 bt7 kernel:  [<0227cc6b>] usb_probe_interface+0x41/0x4b
Dec 10 10:03:40 bt7 kernel:  [<02243a3b>] bus_match+0x27/0x45
Dec 10 10:03:40 bt7 kernel:  [<02243af5>] driver_attach+0x37/0x66
Dec 10 10:03:40 bt7 kernel:  [<02243eaa>] bus_add_driver+0x77/0x97
Dec 10 10:03:40 bt7 kernel:  [<022442c8>] driver_register+0x51/0x58
Dec 10 10:03:40 bt7 kernel:  [<82c458d4>]
usb_serial_register+0x44/0x80 [usbserial]
Dec 10 10:03:40 bt7 kernel:  [<0227cd00>] usb_register+0x3b/0x7a
Dec 10 10:03:40 bt7 kernel:  [<8282f03b>] edgeport_init+0x3b/0x78
[io_edgeport]
Dec 10 10:03:40 bt7 kernel:  [<0213be92>] sys_init_module+0x207/0x2ef
Dec 10 10:03:40 bt7 kernel: Code:  Bad EIP value.
Comment 1 Sitsofe Wheeler 2004-12-11 05:22:50 EST
This might be related to bug #128916
Comment 2 Nick Maliszewskyj 2004-12-13 14:44:03 EST

*** This bug has been marked as a duplicate of 128916 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:39 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.