Bug 1425464 - OSP10 -> OSP11 upgrade fails during gnocchi-upgrade
Summary: OSP10 -> OSP11 upgrade fails during gnocchi-upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-gnocchi
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Pradeep Kilambi
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-21 13:42 UTC by Marius Cornea
Modified: 2018-04-26 19:21 UTC (History)
13 users (show)

Fixed In Version: openstack-gnocchi-3.1.1-0.20170218181806.ca27a17.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:01:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 431101 None None None 2017-02-21 13:43:49 UTC
OpenStack gerrit 432431 None None None 2017-02-21 13:44:11 UTC
Launchpad 1662849 None None None 2017-02-21 13:44:28 UTC

Description Marius Cornea 2017-02-21 13:42:54 UTC
Description of problem:
gnocchi-upgrade fails during Newton -> Ocata overcloud upgrade:

2017-02-08 11:14:45.269 936196 INFO alembic.runtime.migration [-] Running upgrade aba5a217ca9b -> 397987e38570, Remove slashes from original resource IDs, recompute their id with creator
2017-02-08 11:14:45.333 936196 CRITICAL gnocchi [-] DBNonExistentConstraint: (pymysql.err.InternalError) (1091, u"Can't DROP 'fk_metric_resource_id_resource_id'; check that column/key exists") [SQL: u'ALTER TABLE metric DROP FOREIGN KEY fk_metric_resource_id_resource_id']

Version-Release number of selected component (if applicable):
openstack-gnocchi-metricd-3.1.1-0.20170212020154.024ebe4.2.el7ost.noarch
openstack-gnocchi-statsd-3.1.1-0.20170212020154.024ebe4.2.el7ost.noarch
openstack-gnocchi-indexer-sqlalchemy-3.1.1-0.20170212020154.024ebe4.2.el7ost.noarch
openstack-gnocchi-api-3.1.1-0.20170212020154.024ebe4.2.el7ost.noarch
openstack-gnocchi-common-3.1.1-0.20170212020154.024ebe4.2.el7ost.noarch


How reproducible:
100%

Additional info:
We need the following patches in the downstream packages:
https://review.openstack.org/#/c/431101/
https://review.openstack.org/#/c/432431/

Comment 6 errata-xmlrpc 2017-05-17 20:01:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.