Bug 142547 - rsh -l root <host> ls hangs when going to HPUX box
Summary: rsh -l root <host> ls hangs when going to HPUX box
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rsh (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-10 15:44 UTC by Pat Robinson
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-17 18:58:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pat Robinson 2004-12-10 15:44:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2)
Gecko/20040804 Netscape/7.2 (ax)

Description of problem:
rsh -l root <host> ls 

hangs 

rsh -l root 

successfully logs into the box

rsh -l root <host> ls

This command works to the same HPUX host using RedHat 7.3, RedHat 8.0
as well as AIX, IRIX and Solaris platforms.

Version-Release number of selected component (if applicable):
rsh-0.17-17

How reproducible:
Always

Steps to Reproduce:
1. rsh -l root <host> ls   where host is a HPUX box (11.23)
2.
3.
    

Additional info:

Comment 1 Karel Zak 2004-12-13 08:54:48 UTC
The basic diffrence between Red Hat "rsh <command>" and "rsh" is that
the "rsh" without command calls "rlogin" as client. 

It means you need enabled "rlogind" on server side for "rsh" and
"rshd" for "rsh <command>". These commands use differend backend on
server. Please, check your server configuration.

Comment 2 Pat Robinson 2004-12-16 16:31:11 UTC
Yes the configuration on the server is fine.

Like I said this command works from every other platform we have (AIX,
IRIX, Linux 7.3, Linux 8.0, Solaris 8 and 9) to the same HPUX host the
only one that fails is any Advanced Server 3.0 box.  The HPUX is
rx2600 itanium box with HPUX 11.23.  

Comment 3 Karel Zak 2004-12-16 17:12:22 UTC
I think there is minimal diffrence between "rsh" in RHEL3 and old
RedHat8/9. 

Please, read and check:
http://people.redhat.com/kzak/docs/rsh-rlogin-howto.html

maybe you found something interesting. I think a problem can be in
something other than in "rsh" too.

Comment 4 Pat Robinson 2004-12-16 20:27:59 UTC
Aha!  Unbeknownst to me the kerberos rsh is first in the path.  Using
/usr/bin/rsh it is successfull.  Now I guess the question is why does
it fail only going to HPUX??

Comment 5 Karel Zak 2004-12-16 22:06:05 UTC
"rsh" (and other simular stuff) is pretty unsafe so is better try use
more safe version first. The normal behaviour is that kerberos version
if kerberos usage failed calls normal /usr/bin/rsh. Maybe is there
some interaction between your HPUX and kerberosized rsh and it fails
without normal rsh start (or you haven't /usr/bin in root's PATH and
the kerberos version cannot found normal version of rsh). 

I really don't know. But it's fine that you resolve your problem! :-)

Comment 6 Pat Robinson 2004-12-17 17:28:47 UTC
Must be something HP specific because /usr/bin is in root's PATH

Comment 7 Karel Zak 2004-12-17 18:57:25 UTC
But we talked about RH kerberosized client and not about HP server.
Right? ;-)

Comment 8 Karel Zak 2004-12-17 18:58:44 UTC
Sorry.. fotget my last comment...


Note You need to log in before you can comment on or make changes to this bug.