Bug 1425522 - beakerd metrics queries should go to reports_engine if configured
Summary: beakerd metrics queries should go to reports_engine if configured
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: general   
(Show other bugs)
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 24.1
Assignee: Dan Callaghan
QA Contact: Dan Callaghan
URL:
Whiteboard:
Keywords: FutureFeature, Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-21 16:15 UTC by Dan Callaghan
Modified: 2017-02-28 16:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-28 16:50:42 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Callaghan 2017-02-21 16:15:32 UTC
A while back we introduced a config option for an alternative database connection which is used for reporting queries: reports_engine.dburi and related directives in /etc/beaker/server.cfg.

The metrics queries which beakerd periodically runs are a good candidate to be sent to the reporting database, since they are quite expensive but can tolerate using slightly out of date data.

That will let us alleviate some load on the main DB in our production environment, by sending the metrics queries to the MySQL replica which we now have.

Comment 1 Dan Callaghan 2017-02-21 17:05:00 UTC
https://gerrit.beaker-project.org/5644

Comment 5 Dan Callaghan 2017-02-28 16:50:42 UTC
Beaker 24.1 has been released.


Note You need to log in before you can comment on or make changes to this bug.