This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 142554 - Too old Openldap version in rawhide (and fc3)
Too old Openldap version in rawhide (and fc3)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-10 11:45 EST by Dmitry Butskoy
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 10:40:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against upstream configure script (1.97 KB, patch)
2004-12-10 11:49 EST, Dmitry Butskoy
no flags Details | Diff
configure patch against current stable version 2.2.23 (1.98 KB, patch)
2005-03-05 06:53 EST, Dmitry Butskoy
no flags Details | Diff

  None (edit)
Description Dmitry Butskoy 2004-12-10 11:45:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040923

Description of problem:

  Current rawhide version of Openldap is 2.2.13 .
  Current stable upstream version is 2.2.17 (see
http://www.openldap.org/software/download).
  There are a lot of corrected bugs since 2.2.13, including memory
leaks, bdb backend issues etc.

  IMHO, openldap still is not upgraded because of some little trouble.
It is impossible to just put new 2.2.17 tarball into old .spec file.
  Now Openldap`s configure script began to check the version of
Berkeley db on the build system. But RedHat does its own play with db
(special slapd_db.so libs etc.), and it causes configure to fail.

Version-Release number of selected component (if applicable):
openldap-2.2.13-2

How reproducible:
Always

Steps to Reproduce:
Just see upstream ChangeLog in openldap-2.2.17.tar.gz

Additional info:
Comment 1 Dmitry Butskoy 2004-12-10 11:49:05 EST
Created attachment 108327 [details]
Patch against upstream configure script

  This patch removes db-version checks from configure script.
Such check is not needed, because separate db sources are used anyway...

  Using this patch, rpmbuild is OK.

  We use openldap-2.2.17 since September without any problem, IMHO, it is
really stable.
Comment 2 Doncho N. Gunchev 2004-12-16 19:18:48 EST
    I rebuilded the FC3's rpm with openldap-2.2.19 without the
configure patch by just removing 2 or 3 patches (maybe allready in?)
and fixing one slurp's dir. It works for 3 days now. FC3's was dying
every 2-5 days. I'll report how it goes later...
Comment 3 Dmitry Butskoy 2004-12-17 06:47:13 EST
  Doncho,

  Current stable upstream version is still 2.2.17 . IMHO, there are no
reasons to hurry up and get unstable devel version from upstream.
  But 2.2.19 exists already enough long, therefore we can hope that
soon it can be considered stable...
  
Comment 4 Doncho N. Gunchev 2004-12-17 10:18:06 EST
    Yes, I agree, let's wait some more and see how it goes. A friend
had crashes under constant heavy load (?0 000 entries, everything
checked > 20 times a day + replication). We could not find anything in
the log, it just died every 1 to 6 days 'cleanly' and was leaking
memory. According to CHANGES(ChangeLog) .19 fixes 3 more of memleaks
(from .17) and only fixes bugs, no new features - that's why we used
.19. See
http://www.openldap.org/lists/openldap-bugs/200304/msg00131.html for
similar case.
    BTW: The new directory I mentioned is /var/openldap-slurp/replica.
Comment 5 Dmitry Butskoy 2004-12-17 10:32:44 EST
  It may be new features appeared in 2.2.18, and 2.2.19 fixes some
bugs  in this new features :-)

  We use 2.2.17 more than 3 months, without any crashes.

  About replicas: We don`t use slurpd anymore, only new "syncrepl".
All seem to be OK. 
Comment 6 Dmitry Butskoy 2005-01-05 07:40:13 EST
  Openldap 2.2.20 is released, and upstream considers it is stable.
IMHO, it is a good time for upgrade...
Comment 7 Doncho N. Gunchev 2005-02-03 17:00:18 EST
    2.2.23 now :) 2.2.19 still runs fine btw, no single problem while
2.2.13 died on my personal PC too. I'm going to test 2.2.23 if I have
some free time.
Comment 8 Alfred Glanzer 2005-02-07 08:45:44 EST
OPENLDAP 2.2.23 running fine for me for a while now (> 1 week). I
agree it's time to upgrade.

However, nss_ldap > 226 gives severe problems !!! Please see the
bug-reports on this one. Be carefull.
Comment 9 Jarkko 2005-02-25 15:45:26 EST
http://fedora.redhat.com/about/objectives.html

--
Non-Objectives of Fedora Core:

1. Slow rate of change.
--

Please upgrade. FC4 must have newer version. LDAP is very critical
part of the OS nowadays.
Comment 10 Dmitry Butskoy 2005-03-05 06:53:28 EST
Created attachment 111692 [details]
configure patch against current stable version 2.2.23

  It successful compile at working under fc3 .
  Just change 2.2.13 tarball to new 2.2.23 in src.rpm, and add this patch after
all other patches.
Comment 11 Dmitry Butskoy 2005-03-22 10:40:10 EST
  OK, version 2.2.23 in rawhide now, and special configure patch IMHO
no more needed.

  Also note: 2.2.24 is already present, with more bug fixes... :-)

Note You need to log in before you can comment on or make changes to this bug.