Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1425754

Summary: [GSS](6.4.z) Error while starting JBoss as service in domain mode using init scripts.
Product: [JBoss] JBoss Enterprise Application Platform 6 Reporter: Abhijit humbe <abhumbe>
Component: jbossas, Scripts and CommandsAssignee: Radovan STANCEL <rstancel>
Status: CLOSED CURRENTRELEASE QA Contact: Peter Mackay <pmackay>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.4.13CC: bmaxwell, fnasser, jason.greene, jbaesner, oarribas, pmackay, rnetuka, rstancel, wfink
Target Milestone: CR1   
Target Release: EAP 6.4.15   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-19 08:09:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1273093    
Bug Blocks: 1419353    

Description Abhijit humbe 2017-02-22 10:21:05 UTC
Description of problem:
After updating JBoss EAP 6.4.13,we tried to configure JBoss as service in domain mode using init scripts. For this we copy the new jboss-as-domain.sh file to /etc/init.d,  and start the daemon with service jboss-as-domain.sh start,it throw below error:
~~~
Starting jboss-as: /usr/bin/dirname: extra operand `--domain-config=domain.xml'
Try `/usr/bin/dirname --help' for more information.
/
                                                           [  OK  ]

~~~
Version-Release number of selected component (if applicable):
6.4.13
RHEL 6.8

How reproducible:
configure JBoss as service in domain mode.

Steps to Reproduce:
0. update JBOSS_HOME and jboss-as.conf file location in jboss-as-domain.sh script
1. copy init script jboss-as-domain.sh from $JBOSS_HOME/bin/init.d to /etc/init.d
2. Try to start JBoss service using below command:
~~
service jboss-as-domain.sh start
~~ 
3.

Actual results:


Expected results:


Additional info:

Comment 1 oarribas 2017-02-22 12:19:28 UTC
The jboss-as-domain.sh script from EAP 6.4.7 patch works without throws the error. The difference between both scripts is:


EAP 6.4.7:
      daemon --user $JBOSS_USER LAUNCH_JBOSS_IN_BACKGROUND=1 JBOSS_PIDFILE=$JBOSS_PIDFILE $JBOSS_SCRIPT --domain-config=$JBOSS_DOMAIN_CONFIG --host-config=$JBOSS_HOST_CONFIG 2>&1 > $JBOSS_CONSOLE_LOG &


EAP 6.4.13:
      daemon --user $JBOSS_USER "LAUNCH_JBOSS_IN_BACKGROUND=1 JBOSS_PIDFILE=$JBOSS_PIDFILE $JBOSS_SCRIPT --domain-config=$JBOSS_DOMAIN_CONFIG --host-config=$JBOSS_HOST_CONFIG &" 2>&1 > $JBOSS_CONSOLE_LOG

Comment 7 Peter Mackay 2017-05-12 10:01:41 UTC
Verified with EAP 6.4.15.CP.CR3

Comment 8 Petr Penicka 2017-05-19 08:09:55 UTC
Released on May 18 as part of EAP 6.4.15.