Bug 142591 - Nautilus won't always delete files
Summary: Nautilus won't always delete files
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: nautilus   
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-10 20:02 UTC by Ian Laurie
Modified: 2015-01-08 00:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:11:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Laurie 2004-12-10 20:02:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
Now and then Nautilus gets into a mode where it won't delete a file. 
Either when you right-click and select "Move to Trash" or when
highlighting an object and hit the delete key.  Neither will work.
If you launch a shell of course the file can be deleted with "rm".


Version-Release number of selected component (if applicable):
nautilus-2.2.4-4.E

How reproducible:
Sometimes

Steps to Reproduce:
1. Uncertain, it happens regularly but randomly.
2.
3.
    

Actual Results:  Sometimes files cannot be deleted with Nautilus.

Expected Results:  Files should be deleted by Nautilus when required.

Additional info:

If you kill all instances of Nautilus, and Nautilus re-spawns, file
deleting works again.  Also logging out and in again does it (because
all instances of Nautilus get killed).

Just quiting a single interactive session of Nautilus and restarting
another does NOT fix it.  Nautilus must die completely as a session
manager for the problem to fix itself.

Comment 1 RHEL Product and Program Management 2007-10-19 19:11:33 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.