Bug 1425925 - Install pending updates does not honor dnf excludes
Summary: Install pending updates does not honor dnf excludes
Keywords:
Status: CLOSED DUPLICATE of bug 1256108
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-22 18:36 UTC by David Reed
Modified: 2017-02-22 22:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-22 22:26:31 UTC
Type: Bug


Attachments (Terms of Use)

Description David Reed 2017-02-22 18:36:44 UTC
Description of problem:
After selecting the "Install pending software updates" on system reboot, by system installed packages that I had explicitly excluded in /etc/dnf/dnf.conf

Version-Release number of selected component (if applicable):
1.1.5

How reproducible:
Always

Steps to Reproduce:
1.Add a package that has a pending update to /etc/dnf/dnf.conf exclude list
2.Update via system reboot/shutdown by selecting the "Install pending software updates" checkbox

Actual results:
Package is updated

Expected results:
Exclude list is honored and package is not updated

Additional info:
This is a possible duplicate of bug 1259865, but I felt that it was different enough to warrant a new bug report.  If not, I apologize... this is my first bug report.

Comment 1 Rex Dieter 2017-02-22 22:26:31 UTC
Dup of bug #1256108

*** This bug has been marked as a duplicate of bug 1256108 ***


Note You need to log in before you can comment on or make changes to this bug.