Bug 142600 - FC3 NFS install served from FC3 distro fails
FC3 NFS install served from FC3 distro fails
Status: CLOSED DUPLICATE of bug 157729
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-12-10 15:21 EST by Michael M. Morrison
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-05-16 10:17:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael M. Morrison 2004-12-10 15:21:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Attempts to install FC3 via NVS from a server running the FC3
distribution fail.  Fails regardless of whether the directory is
filled with an "install tree" or just the 4 ISO's.  The installation
window hangs - providing no error indication, you have to consult the
background VT's to get further information.

Version-Release number of selected component (if applicable):
Fedora Core 3

How reproducible:

Steps to Reproduce:
1.  Install FC3 on the server.  Download all yum updates.
2.  Copy ISOs to export directory, and export it in /etc/exports.
3.  Boot FC3 Disc 1 on install client.
4.  at prompt, select "linux askmethod"
5.  configure ethernet, select server and directory
6.  begin install

Actual Results:  With a directory containing ISOs, the install fails
with the error "Unable to find Fedora/base/stage2.img", which is
correct - as that file exists in the ISO image.

With a directory containing an "install tree" (the files copied from
the install CDs) the install also fails (hangs) and the back VT claims
that the NFS server has timed out - although the server NFS still
appears to be working.

Expected Results:  The installer should have recognized the ISO
images, and installed using them.  I am not sure why the NFS server
times out, if it really does.

Additional info:

An FTP install using the same client and server and an "install tree"
configuration worked fine.
Comment 1 Jeremy Katz 2004-12-13 20:47:59 EST
This works for me here.  Do you have the src isos in the same directory?
Comment 2 Michael M. Morrison 2004-12-16 05:31:50 EST
No, but I did have the FC3-i386-rescuecd.iso and an MD5SUM file in the

FC3-i386-disc1.iso  FC3-i386-disc3.iso  FC3-i386-rescuecd.iso
FC3-i386-disc2.iso  FC3-i386-disc4.iso  MD5SUM
Comment 3 Chris Lumens 2005-05-16 10:17:30 EDT
Marking as a duplicate of a bug filed later because the later one has a lot of
useful debugging output attached to it.  Thanks for the report.

*** This bug has been marked as a duplicate of 157729 ***

Note You need to log in before you can comment on or make changes to this bug.