Bug 142609 - emacs crashes running under the X from FC3
emacs crashes running under the X from FC3
Status: CLOSED DUPLICATE of bug 137685
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-12-10 16:18 EST by H. Peter Anvin
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-01-31 15:36:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description H. Peter Anvin 2004-12-10 16:18:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5) Gecko/20041110 Firefox/1.0

Description of problem:
When running emacs in an X window under Fedora Core 3, it frequently crashes with the message:

X protocol error: BadWindow (invalid Window parameter) on protocol request 25

... or something similar.

This is not limited to the local machine only; for example, if I ssh into a machine running Fedora Core 2 and run emacs, it has the same behaviour.  (Obviously, if I disable X forwarding and/or use the -nw option, this doesn't happen, but then emacs is crippled.)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run emacs in an X window on a stock Fedora Core 3 system.
2. Do a bunch of editing.

Actual Results:  Sooner or later, it will crash.  This applies even if it is an emacs from another machine.

Additional info:
Comment 1 Mike A. Harris 2004-12-10 19:52:35 EST
This is covered in the Fedora Core 3 release notes.
Comment 2 Sitsofe Wheeler 2004-12-11 05:32:51 EST
Very similar to bug #138617
Comment 3 Tomas Mraz 2005-01-31 15:35:31 EST

*** This bug has been marked as a duplicate of 137685 ***

Note You need to log in before you can comment on or make changes to this bug.